Subject: [homenet] drafts on github

From: Daniel Migault <[email-masked]>
Date: Fri, 3 Aug 2018 18:01:59 -0400

Hi,

To ease collaboration I have converted to mkd the following drafts
https://github.com/mglt/ietf-homenet-hna
https://github.com/mglt/ietf-homenet-hna-dhcp

I suggest we focus on the front-end-naming architecture draft, and I will
catch up comments I have not yet answered.

During IETF102, I git that the draft was too long. I believe that is
resulting from considering all feed backs and details. Though I believe
these are important pieces, I agree that some of them could be better
placed in an appendix. I would be happy to get what the WG wants to put in
appendix as well  as how the WG expects to shorten the draft.

Yours,
Daniel

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 8 Aug 2018 18:31:52 +0000

Daniel: Thanks for doing this.
Just to add more change (no that’s not really the reason – the reason is to formalize things with official Note Wells and integrated IETF tools and such), we have an official homenet-wg github site (https://github.com/ietf-homenet-wg). I’ve put the front-end-naming-delegation draft there. I did just a little bit to the .mkd Daniel created to make it Linux compatible (get rid of annoying end-of-line characters), added and deleted spaces to make markdown happy, and I successfully made the IETF tools stop complaining. And changed the extension to .md. The only “real” thing I changed was the howard-dnsop-ip6rdns draft reference to ietf-dnsop-ip6rdns. kramdown-rfc2629 successfully creates a .xml file for this .md; and xml2rfc successfully creates .html and .txt from that .xml.

Daniel, you should now have permission to do things to this draft? I need to add the other editors to the team – maybe if editors could unicast me with your github user names?

Next is -dhc-options. I see Tomek has been doing things, so I don’t want to set up the repository for this one till I know I have the latest.
Barbara

From: homenet <[email-masked]> On Behalf Of Daniel Migault
Sent: Friday, August 03, 2018 6:02 PM
To: homenet <[email-masked]>
Subject: [homenet] drafts on github

Hi,

To ease collaboration I have converted to mkd the following drafts
https://github.com/mglt/ietf-homenet-hna<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_mglt_ietf-2Dhomenet-2Dhna&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=FrRSaiTH66MBu88Ak5XafPnsi7Qdnj4a4gTAl3YxT2s&s=xy5awYNRsgUfRyqV3UlPazhOMRjt4n1aiU6LjQnlFsw&e=>
https://github.com/mglt/ietf-homenet-hna-dhcp<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_mglt_ietf-2Dhomenet-2Dhna-2Ddhcp&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=FrRSaiTH66MBu88Ak5XafPnsi7Qdnj4a4gTAl3YxT2s&s=lONpk_js4I4QCk_Hy0E0gahtfAZUpFXjgazVw5Bl93w&e=>

I suggest we focus on the front-end-naming architecture draft, and I will catch up comments I have not yet answered.

During IETF102, I git that the draft was too long. I believe that is resulting from considering all feed backs and details. Though I believe these are important pieces, I agree that some of them could be better placed in an appendix. I would be happy to get what the WG wants to put in appendix as well  as how the WG expects to shorten the draft.

Yours,
Daniel

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 8 Aug 2018 20:15:40 +0000

I’ve now finished the repository for -dhc-options, too. I saw the commits from Tomek were very old.
I think everything looks ok at https://github.com/ietf-homenet-wg<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_ietf-2Dhomenet-2Dwg&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=xJQYsIFCM35uMQ5MDj-YlmXIi_drhqjrHnY0LsqXxfE&s=ypiN3AFgUPz_gdC-nSWRcdleQLWemq4qcWmwVwScFrQ&e=>, and the tools seem to work.
So I think that mainly just leaves setting up the editors and additional aotomations.
Barbara

for more information.
Daniel: Thanks for doing this.
Just to add more change (no that’s not really the reason – the reason is to formalize things with official Note Wells and integrated IETF tools and such), we have an official homenet-wg github site (https://github.com/ietf-homenet-wg<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_ietf-2Dhomenet-2Dwg&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=xJQYsIFCM35uMQ5MDj-YlmXIi_drhqjrHnY0LsqXxfE&s=ypiN3AFgUPz_gdC-nSWRcdleQLWemq4qcWmwVwScFrQ&e=>). I’ve put the front-end-naming-delegation draft there. I did just a little bit to the .mkd Daniel created to make it Linux compatible (get rid of annoying end-of-line characters), added and deleted spaces to make markdown happy, and I successfully made the IETF tools stop complaining. And changed the extension to .md. The only “real” thing I changed was the howard-dnsop-ip6rdns draft reference to ietf-dnsop-ip6rdns. kramdown-rfc2629 successfully creates a .xml file for this .md; and xml2rfc successfully creates .html and .txt from that .xml.

From: homenet <[email-masked]<mailto:[email-masked]>> On Behalf Of Daniel Migault
Sent: Friday, August 03, 2018 6:02 PM
To: homenet <[email-masked]<mailto:[email-masked]>>
Subject: [homenet] drafts on github

Hi,

Yours,
Daniel

---

From: Daniel Migault <[email-masked]>
Date: Wed, 8 Aug 2018 18:11:14 -0400

Thank you Barbara for the setting! I can see the drafts on the git!

Yours,
Daniel

On Wed, Aug 8, 2018 at 4:15 PM, STARK, BARBARA H <[email-masked]> wrote:

> I think everything looks ok at https://github.com/ietf-homenet-wg
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_ietf-2Dhomenet-2Dwg&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=xJQYsIFCM35uMQ5MDj-YlmXIi_drhqjrHnY0LsqXxfE&s=ypiN3AFgUPz_gdC-nSWRcdleQLWemq4qcWmwVwScFrQ&e=>,
> and the tools seem to work.
>
> Just to add more change (no that’s not really the reason – the reason is
> to formalize things with official Note Wells and integrated IETF tools and
> such), we have an official homenet-wg github site (
> https://github.com/ietf-homenet-wg
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_ietf-2Dhomenet-2Dwg&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=xJQYsIFCM35uMQ5MDj-YlmXIi_drhqjrHnY0LsqXxfE&s=ypiN3AFgUPz_gdC-nSWRcdleQLWemq4qcWmwVwScFrQ&e=>).
> I’ve put the front-end-naming-delegation draft there. I did just a little
> bit to the .mkd Daniel created to make it Linux compatible (get rid of
> annoying end-of-line characters), added and deleted spaces to make markdown
> happy, and I successfully made the IETF tools stop complaining. And changed
> the extension to .md. The only “real” thing I changed was the
> howard-dnsop-ip6rdns draft reference to ietf-dnsop-ip6rdns.
> kramdown-rfc2629 successfully creates a .xml file for this .md; and xml2rfc
> successfully creates .html and .txt from that .xml.
>
>
>
> Daniel, you should now have permission to do things to this draft? I need
> to add the other editors to the team – maybe if editors could unicast me
> with your github user names?
>
>
>
> Next is -dhc-options. I see Tomek has been doing things, so I don’t want
> to set up the repository for this one till I know I have the latest.
>
> Barbara
>
>
>
>
>
>
>
> *From:* homenet <[email-masked]> *On Behalf Of *Daniel Migault
> *Sent:* Friday, August 03, 2018 6:02 PM
> *To:* homenet <[email-masked]>
> *Subject:* [homenet] drafts on github
>
>
>
> Hi,
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_mglt_ietf-2Dhomenet-2Dhna&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=FrRSaiTH66MBu88Ak5XafPnsi7Qdnj4a4gTAl3YxT2s&s=xy5awYNRsgUfRyqV3UlPazhOMRjt4n1aiU6LjQnlFsw&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_mglt_ietf-2Dhomenet-2Dhna-2Ddhcp&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=FrRSaiTH66MBu88Ak5XafPnsi7Qdnj4a4gTAl3YxT2s&s=lONpk_js4I4QCk_Hy0E0gahtfAZUpFXjgazVw5Bl93w&e=>
>
>
>
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>
>