Subject: Re: [hrpc] Cases - P2P

From: Bryan Ford <[email-masked]>
Date: Mon, 2 Nov 2015 05:40:26 +0900

> On Oct 11, 2015, at 9:45 AM, Nex <[email-masked]> wrote:
> 
> Hello everybody.
> Here are some initial considerations on P2P networks. This is a complex
> one to address as implementations and use cases vary so much. I'm sure
> it needs to be expanded upon, but this could a starting point.

Nice.  One critical subsection I think it needs to have is one on Sybil attacks, one of the most fundamental “P2P-killer” problems. :)  

Some possible starting-point text:

	Sybil Attacks

In open-membership P2P networks, a single attacker can pretend to be many participants, typically by creating multiple fake identities of whatever kind the P2P network uses [X,Y].  Attackers can use Sybil attacks to bias choices the P2P network makes collectively toward the attacker’s advantage, e.g., by making it more likely that a particular data item (or some threshold of the replicas or shares of a data item) are assigned to attacker-controlled participants.  If the P2P network implements any voting, moderation, or peer review-like functionality, Sybil attacks may be used to “stuff the ballots” toward the attacker’s benefit.  Companies and governments can use Sybil attacks on discussion-oriented P2P systems for “astroturfing” or creating the appearance of  mass grassroots support for some position where there is none in reality.  

[X] John R. Douceur, The Sybil Attack. http://research.microsoft.com:8082/pubs/74220/IPTPS2002.pdf

Cheers
Bryan

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 02 Nov 2015 01:44:11 +0100

Dear Bryan,

Thanks a lot for this, I've added this to the draft [0] and will push
it when we can publish again, later this week.

Best,

Niels

[0] https://github.com/nllz/IRTF-HRPC/blob/master/draft-methodology.md

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                   678B 08B5 A0F2 636D 68E9

On 11/01/2015 09:40 PM, Bryan Ford wrote:
>> Hello everybody. Here are some initial considerations on P2P
>> networks. This is a complex one to address as implementations and
>> use cases vary so much. I'm sure it needs to be expanded upon,
>> but this could a starting point.
> 
> Nice.  One critical subsection I think it needs to have is one on
> Sybil attacks, one of the most fundamental “P2P-killer” problems.
> :)
> 
> In open-membership P2P networks, a single attacker can pretend to
> be many participants, typically by creating multiple fake
> identities of whatever kind the P2P network uses [X,Y].  Attackers
> can use Sybil attacks to bias choices the P2P network makes
> collectively toward the attacker’s advantage, e.g., by making it
> more likely that a particular data item (or some threshold of the
> replicas or shares of a data item) are assigned to
> attacker-controlled participants.  If the P2P network implements
> any voting, moderation, or peer review-like functionality, Sybil
> attacks may be used to “stuff the ballots” toward the attacker’s
> benefit.  Companies and governments can use Sybil attacks on
> discussion-oriented P2P systems for “astroturfing” or creating the
> appearance of  mass grassroots support for some position where
> there is none in reality.
> 
> [X] John R. Douceur, The Sybil Attack.
> http://research.microsoft.com:8082/pubs/74220/IPTPS2002.pdf
> 
> Cheers Bryan
> 
> 
> 
> 
> _______________________________________________ hrpc mailing list 
> [email-masked] https://www.irtf.org/mailman/listinfo/hrpc
>

---

From: Nex <[email-masked]>
Date: Mon, 2 Nov 2015 16:52:18 +0100

> [X] John R. Douceur, The Sybil Attack. http://research.microsoft.com:8082/pubs/74220/IPTPS2002.pdf

Thanks Bryan, that's a very good point.

/nex