Subject: [hrpc] Fwd: New Version Notification for draft-nottingham-for-the-users-03.txt

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Aug 2016 16:27:16 +0200

FYI. The major change here is that the requirements around documenting relevant parties have been softened to suggestions; the only requirement in the document is that end users have precedence.

It probably needs some more language around what an "end user" is.

Prettier version at:
  https://mnot.github.io/I-D/for-the-users/

As always, feedback welcome.

Cheers,

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-nottingham-for-the-users-03.txt
> Date: 3 August 2016 at 4:25:23 PM GMT+2
> To: "Mark Nottingham" <[email-masked]>
> 
> 
> A new version of I-D, draft-nottingham-for-the-users-03.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Name:		draft-nottingham-for-the-users
> Revision:	03
> Title:		The Internet is for End Users
> Document date:	2016-08-03
> Group:		Individual Submission
> Pages:		9
> URL:            https://www.ietf.org/internet-drafts/draft-nottingham-for-the-users-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-nottingham-for-the-users/
> Htmlized:       https://tools.ietf.org/html/draft-nottingham-for-the-users-03
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-nottingham-for-the-users-03
> 
> Abstract:
>   Internet standards serve and are used by a variety of communities.
>   This document makes suggestions for explicitly identifying them,
>   serving them, and determining how to resolve conflicts between their
>   interests, when necessary.
> 
>   It also requires that Internet Standards consider end users as their
>   highest priority concern.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: John Curran <[email-masked]>
Date: Wed, 3 Aug 2016 11:18:23 -0400

> It probably needs some more language around what an "end user" is.

Mark - 
 
Excellent draft.  I will note that there is some inherent difficultly in implementation of
the main principle (i.e. "Internet standards MUST NOT consider any other party to 
have higher priority over end users.”), and it comes from the fact that sometimes 
the other parties may actually be proxies for the interests of particular segments 
of the end-user community.

For example, no one generally speaks for the need of fire departments, until they 
are part of that very small portion of the population whose homes have been on fire…
Similarly, most folks do not have express a direct interest in smoke detectors, but the 
very high level of interest for those who needed them (when they needed them) means
that it is not always so simple to understand the overall interests of a large community 
simply by engaging in discussion of what is their most widely held views.

I don’t think this undermines the value of the draft in any manner, and note that this 
difficulty is recognized somewhat with respect to information security (where it notes 
that “end users cannot be reasonably expected to make informed decisions about 
security…” thus resulting in computer security experts representing their default 
security requirements; i.e. there may be other circumstances where it is difficult for
the end-users community to engage in informed decision making, simply due to lack 
of familiarity with the details that might be unique to a subset of their population.

In short, significant care will be needed in applying the principles in the document
to ensure that the interests of end-users are protected, even those interests which
are not common but involve significant adverse consequences for those end-users
who are affected.  Some situations that come to mind offhand include tradeoffs in
end-user interests regarding accessibility accommodation, victims of criminal activity, 
diverse language support, etc.

Excellent job on the draft - thanks for writing this!
/John

Disclaimer: my views alone

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Aug 2016 14:37:48 +1000

Hi John,

Thanks. I agree, and suspect that some wordsmithing might at least help people misunderstand it less. As it tries to point out, it's always going to take some interpretation. 

Suggestions welcome!

> On 4 Aug 2016, at 1:18 AM, John Curran <[email-masked]> wrote:
>