Subject: Re: [hrpc] Fwd: New Version Notification for draft-tenoever-hrpc-association-03.txt

From: Niels ten Oever <[email-masked]>
Date: Tue, 20 Mar 2018 20:51:54 +0100

On 02/22/2018 03:09 PM, Stephane Bortzmeyer wrote:
> On Fri, Feb 16, 2018 at 09:50:57PM +0100,
>  Niels ten Oever <[email-masked]> wrote 
>  a message of 76 lines which said:
> 
>> Gisela and I are very happy to share a new version of the
>> association draft with you.
> 
> Summary: I agree, I think it is important, and I think the synthesis
> in section 8, and its conclusion, are fine.
> 
> Now, the details.
> 
>> The Internet provides a global public space, but one that is built
>> on private infrastructure.
> 
> *Mostly* (may be) on private infrastructure but not all. NRENs are a
> good example of public infrastructure, but there are others. (Even
> more if you regard DNS registries as infrastructure.)
> 

Agreed, changed into:

"but one that is built for the most part on private infrastructure"

>> This is also true for the Border Gateway Protocol
> 
> The last paragraph of section 6 is very confused. The fact that "there
> is no transparency about the routes that packets have taken" has
> nothing to do with BGP (it is an IP issue, since "record route" - RFC
> 791, section 3.1 - was never deployed). Pull Request incoming.
> 

Thanks!

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 22 Mar 2018 10:24:35 +0000

On Tue, Mar 20, 2018 at 08:51:54PM +0100,
 Niels ten Oever <[email-masked]> wrote 
 a message of 36 lines which said:

> > The last paragraph of section 6 is very confused. The fact that
> > "there is no transparency about the routes that packets have
> > taken" has nothing to do with BGP (it is an IP issue
> 
> Thanks!

But I cannot find it in -04, which has still the (IMHO) wrong version.

---

From: Niels ten Oever <[email-masked]>
Date: Thu, 22 Mar 2018 13:31:10 +0100

> But I cannot find it in -04, which has still the (IMHO) wrong version.

To my great shame I had not properly integrated the Pull Request, but
have done so now:

https://github.com/nllz/IRTF-HRPC/commit/38c9cdc9396b2b65c094d787b60e00c6f8fd05b6#diff-8bf5915675feadf7368fb670e2e3e688

Best,

Niels