Subject: [http-auth] Fwd: I-D Action: draft-morand-http-digest-2g-aka-03.txt

From: Sean Turner <[email-masked]>
Date: Tue, 03 Sep 2013 09:35:57 -0400

Hi!

The following draft is currently on the IESG telechat for next week and 
as part of the process an AD does what's called and "RFC 5742 review", 
which is basically a check to see if there's been an endrun on the 
process.   This draft has been around for a while and I know it was at 
least discussed on the httpbis wg mailing list in early '12 (and maybe 
even earlier), but that was before the httpauth working group was 
chartered.  So I gotta ask: Is this something that the working group 
should consider adopting?

spt
-------- Original Message --------
Subject: I-D Action: draft-morand-http-digest-2g-aka-03.txt
Date: Mon, 21 Jan 2013 10:16:39 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title           : Hypertext Transfer Protocol (HTTP) Digest 
Authentication Using GSM 2G Authentication and Key Agreement (AKA)
	Author(s)       : Lionel Morand
	Filename        : draft-morand-http-digest-2g-aka-03.txt
	Pages           : 15
	Date            : 2013-01-21

Abstract:
    This memo specifies a one-time password generation mechanism for
    Hypertext Transfer Protocol (HTTP) Digest access authentication based
    on Global System for Mobile Communications (GSM) authentication and
    key generation functions A3 and A8, also known as GSM AKA or 2G AKA.
    The HTTP Authentication Framework includes two authentication
    schemes: Basic and Digest.  Both schemes employ a shared secret based
    mechanism for access authentication.  The GSM AKA mechanism performs
    user authentication and session key distribution in GSM and Universal
    Mobile Telecommunications System (UMTS) networks.  GSM AKA is a
    challenge-response based mechanism that uses symmetric cryptography.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-morand-http-digest-2g-aka

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-morand-http-digest-2g-aka-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-morand-http-digest-2g-aka-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Yoav Nir <[email-masked]>
Date: Tue, 3 Sep 2013 17:39:23 +0000

Hi Sean,

Looking over the discussion in httpbis ([1]), it's not clear to me whether this is documenting existing practice or whether it's proposing a new method. Either way, this method seems specific to a domain, where I believe the author has much more expertise than people in the working group. I am personally fine with it proceeding as an independent submission. I would also be fine with the working group discussing this, but I don't know how much value we could add.

Yoav (with no hats)
[1] http://lists.w3.org/Archives/Public/ietf-http-wg/2012AprJun/0375.html

On Sep 3, 2013, at 4:35 PM, Sean Turner <[email-masked]> wrote:

> Hi!
> 
> The following draft is currently on the IESG telechat for next week and as part of the process an AD does what's called and "RFC 5742 review", which is basically a check to see if there's been an endrun on the process.   This draft has been around for a while and I know it was at least discussed on the httpbis wg mailing list in early '12 (and maybe even earlier), but that was before the httpauth working group was chartered.  So I gotta ask: Is this something that the working group should consider adopting?
> 
> spt
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Hypertext Transfer Protocol (HTTP) Digest Authentication Using GSM 2G Authentication and Key Agreement (AKA)
> http-auth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-auth

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 04 Sep 2013 00:33:10 +0300

While I agree with Yoav that this draft requires expertise that we 
(httpauth) probably do not have, I also have a major issue with the draft.

Although TLS is proposed as a solution for mutual auth, there are no 
requirements on the server's identity and so there is no way specified 
to actually authenticate the server.

As a result, I suspect that this method can be used by a MITM attacker 
to impersonate another IMSI ("user" in common terms) for regular 
AKA-based authentication.

Thanks,
	Yaron

---

From: <[email-masked]>
Date: Wed, 4 Sep 2013 12:52:16 +0000

Hi Yaron,

I was assuming that the TLS specific requirements could have been left out of this document, as these requirements/recommendations can be found in other documents (e.g. RFCs or 3GPP specifications) and it is assumed that people using such TLS certificate-based server authentication will refer to them. 

In the mobile context, it is assumed that the client uses a preconfigured list of trusted root certificates for server certificate validation. The use of a small set of CAs trusted by the home mobile operator limits the risk of root certificates associated with a compromised CA.

I don't know if such details are needed in the doc. What would be your recommendation?

About Independent Submission vs. WG document, as I said, I have no strong opinion. It was concluded that the mechanism was maybe too specific to be part of the new httpauth WG charter. The same conclusion was reached about the discussion on moving RFC3310 (Digest 3G AKA) from informational to Proposed Standard RFCs. There was no intention to bypass any specific expertise. The idea is just to document within IETF the Digest 2G AKA mechanism, as a companion of the RFC3310.

Regards,

Lionel

-----Message d'origine-----
De : Yaron Sheffer [mailto:[email-masked]] 
Envoyé : mardi 3 septembre 2013 23:33
À : Yoav Nir
Cc : Sean Turner; <[email-masked]>; MORAND Lionel IMT/OLN
Objet : Re: [http-auth] I-D Action: draft-morand-http-digest-2g-aka-03.txt

Thanks,
	Yaron

>> ftp://ftp.ietf.org/internet-drafts/

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 04 Sep 2013 13:57:23 +0100

Hi Lionel,

On 09/04/2013 01:52 PM, [email-masked] wrote:
> The idea is just to document within IETF the Digest 2G AKA mechanism,
> as a companion of the RFC3310.

Can you clarify if the draft describes some existing deployment
or if its a new proposal? (I think it'd be great if the draft
itself made that clear.)

Thanks,
S.

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 04 Sep 2013 16:49:09 +0300

Hi Lionel,

I would recommend to include your clarification in the document, and if 
possible, references to the relevant documents. In a world where many 
phishing attacks use valid certificates 
(http://www.thewhir.com/web-hosting-news/report-netcraft-sees-valid-ssl-certificates-on-phishing-sites), 
saying "just use TLS" is unfortunately not enough.

Thanks,
	Yaron

---

From: <[email-masked]>
Date: Wed, 4 Sep 2013 14:03:17 +0000

Hi Stephen,

For the record, in mobile networks, Digest mechanism is first over SIP (IMS), then over HTTP (GBA - Generic Bootstrapping Architecture). When introduced, only 3G mobile subscribers (with 3G smartcards) were considered and Digest was enhanced to support the 3G AKA authentication method. Now, considering that a lot of mobile users will remain with their 2G SIM card for a while, GBA was enhanced to support 2G users by deriving 3G authentication vectors from 2G authentications vectors. The problem is that this derivation mechanism is not always supported and it makes difficult to use it. Defining a simple Digest 2G AKA mechanism would remove this need for derivation and make simpler he deployment of simcard based authentication.

Some solutions have been developed based on the material available in and some other deployments would require such mechanism to enable simcard-based HTTP authentication over untrusted environment (e.g. free hotspots) to access mobile operator environment/services.
This draft-ietf-http-digest-auth-a3a8-01 has expired and the author did not want to go on the publication effort. And I then proposed to publish it as informational RFC some times before all the discussions on the HTTP-bis or HTTP-Auth.

So, in brief, I'm not aware of large deployment using this mechanism but there is a confirmed requirement for such mechanism.

Regards,

Lionel

-----Message d'origine-----
De : Stephen Farrell [mailto:[email-masked]] 
Envoyé : mercredi 4 septembre 2013 14:57
À : MORAND Lionel IMT/OLN
Cc : Yaron Sheffer; Yoav Nir; <[email-masked]>
Objet : Re: [http-auth] I-D Action: draft-morand-http-digest-2g-aka-03.txt

Hi Lionel,

Thanks,
S.

---

From: <[email-masked]>
Date: Thu, 5 Sep 2013 17:14:01 +0000

Will be done! 

Thank you!

-----Message d'origine-----
De : Yaron Sheffer [mailto:[email-masked]] 
Envoyé : mercredi 4 septembre 2013 15:49
À : MORAND Lionel IMT/OLN
Cc : Yoav Nir; Sean Turner; <[email-masked]>
Objet : Re: [http-auth] I-D Action: draft-morand-http-digest-2g-aka-03.txt

Hi Lionel,

Thanks,
	Yaron