Subject: Re: [http-auth] Proposed Virtual Interim Meeting about MutualAuth

From: Yutaka OIWA <[email-masked]>
Date: Mon, 2 Sep 2013 12:47:50 +0900

Dear Yoav and all list members,

I agree that 15:00Z is the most convenient (or more precisely,
the least inconvenient :-) for most of us in the group.
< http://www.timeanddate.com/worldclock/meetingtime.html?iso=20131008&p1=248&p2=224&p3=179&p4=195

## One hour earlier is more convenient for us in Japan, but it gives
## 7am in San Francisco and Vancouver.
## One hour later will bring us adverse battles against drowsiness :-)

The date is also fine with 15:00 UTC, Tuesday, October 8th
(i.e. 00:00 JST (+0900), Wednesday, October 9th ... please correct me
if it's wrong).

Our Mutual-auth team members are planning to be gathering
around the same table at that time (somewhere in Japan), if possible,
so that we can respond quickly for any possible issues.

Thank you very much for arranging it!

2013/8/28 Yoav Nir <[email-masked]>:
> Hi all
>
> Of all the experimental proposals, MutualAuth has been around for the longest time. There is running code ([1],[2]) and documentation for years. While it is not deployed in either commercial products or popular open source projects, this is the best that we can hope for in terms of maturity for the documents that this group is working on.
>
> With that in mind, we would like the reviews of the MutualAuth proposal to begin now. Those who committed to review this, please send your comments to the list within the next few weeks, and others are welcome to do so as well.
>
> We would also like to hold a virtual interim meeting early October. Time of day is difficult, because we truly are an international group. 8:00 AM in California is OK for Europe but is midnight in Japan. That (1500 UTC) still looks to me like the least combined pain proposal. If others feel differently, please let me know. For date, I'm thinking Tuesday, October 8th.
>
> If this conflicts with someone who wants to participate, please let Matt and I know soon, because interim meetings (even virtual ones) have to be announced a month in advnace.
>
> Also, if you plan to attend, please let us know. We are talking about a virtual interim meeting, so the technology is probably going to be a PSTN conference call. Details will be sent later on.
>
> Thanks,
>
> Matt & Yoav
>
> _______________________________________________
> http-auth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-auth

-- 
Yutaka OIWA, Ph.D.                 Leader, System Life-cycle Research Group
                               Research Institute for Secure Systems (RISEC)
     National Institute of Advanced Industrial Science and Technology (AIST)
                       Mail addresses: <[email-masked]>, <[email-masked]>
OpenPGP: id[440546B5] fp[7C9F 723A 7559 3246 229D  3139 8677 9BD2 4405 46B5]

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 02 Sep 2013 08:50:39 +0100

Hi Yoav,

The meeting time is ok for me but I'm confused as to the topic.

Is the proposed virtual about 1) mutualauth only or 2) about all
of the experimental proposals and potential commonalities between
them all?

I'm not really interested in (1), but will dutifully turn up if
I can.

I am interested in (2), and thought that's what we talked about
in Berlin as the topic of a virtual interim.

I also don't think that we'll have enough energy for N virtual
interims which would again argue that the agenda ought not be
limited to just one of the proposals.

S.

PS: Yes, mutualauth has been around longest. I do not agree that
that is the best we can hope for in terms of maturity, but maybe
that's just me being an optimist:-)

---

From: Yoav Nir <[email-masked]>
Date: Mon, 2 Sep 2013 08:54:13 +0000

Hi Stephen.

The plan is (1), and this would be the only virtual interim between now and Vancouver. I think only httpbis has enough energy to hold two interims between every two regular meetings.

If all goes well, and we discuss all open issues at the interim, we can maybe go to WGLC around the Vancouver meeting time, and then use the face-2-face meeting to discuss the other experimental proposals. After Vancouver we'll decide again whether we need another interim before London, but I think it's best to focus each interim on a single document.

Yoav

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 02 Sep 2013 10:27:39 +0100

Hiya,

On 09/02/2013 09:54 AM, Yoav Nir wrote:
> Hi Stephen.
> 
> The plan is (1), and this would be the only virtual interim between
> now and Vancouver. I think only httpbis has enough energy to hold two
> interims between every two regular meetings.
> 
> If all goes well, and we discuss all open issues at the interim, we
> can maybe go to WGLC around the Vancouver meeting time, and then use
> the face-2-face meeting to discuss the other experimental proposals.
> After Vancouver we'll decide again whether we need another interim
> before London, but I think it's best to focus each interim on a
> single document.

fwiw, I disagree that this is the best approach, but you're
the chairs so its your call.

My disagreement (in order of importance) is because:

a) I think the interesting issue for discussion is whether there
is any useful commonality between the various exp proposals
that ought be reflected in the various drafts, and logically
that needs to be discussed before WGLC for any of 'em or else
we're implicitly deciding to leave that for after they become
RFCs (which could be an ok outcome but that should be an
explicit wg decision IMO - see below for why),

b) I don't think we'll have enough energy for productive
virtual meetings for each of the exp proposals so doing it
your way may result in one or maybe two getting some real
discussion, and one-per-proposal will also drag things out
for no particularly good reason IMO,

and c) based on my review to date, I don't think that
mutualauth will be finished that soon (great if it is
though).

But, if nobody else cares much I guess I'm just in the rough
on that, which is ok too.

If we're going ahead with your plan can you start a separate
thread to try make the "don't bother with common text" decision
explicit before this meeting happens? I'm quite sure that'll
come up in WGLC/IETF LC/IESG review so it'll be better if there's
a thread to which document shepherds can point folks who raise
this issue later on.

Cheers,
S.

PS: As a nit, I'll note that mutualauth is not a single
document but rather proposal that's documented in a set of
3 drafts. I don't believe it makes sense to evaluate just
one draft but rather the entire thing has to be considered
if e.g. your goal of documenting known weaknesses etc can
be met.

>> Is the proposed virtual about 1) mutualauth only or 2) about all of
>> the experimental proposals and potential commonalities between them
>> all?
>> 
>> I'm not really interested in (1), but will dutifully turn up if I
>> can.
>> 
>> I am interested in (2), and thought that's what we talked about in
>> Berlin as the topic of a virtual interim.
>>