Subject: [http-auth] Fwd: [Cfrg] Another PAKE question

From: Yoav Nir <[email-masked]>
Date: Thu, 9 Jan 2014 15:24:36 +0000

Hi.

CFRG has recently had some discussion about PAKEs in general. I have asked them to take a look at MutualAuth. This is one of the replies that we got.

Yoav

Begin forwarded message:

From: Watson Ladd <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Cfrg] Another PAKE question
Date: January 9, 2014 4:57:19 PM GMT+02:00
To: Yoav Nir <[email-masked]<mailto:[email-masked]>>

Why is this protocol secure?
I would recommend taking the z, and computing a hash of z and the
transcript of the protocol. In
this way under the ROM, the computed value doesn't reveal information.
It ensures that any
manipulation of the messages leads to different z values.

I'll try to think of ways to make a proof given that change.
Sincerely,
Watson Ladd

On Wed, Jan 8, 2014 at 10:09 PM, Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:
Hi

I almost feel like I'm asking for trouble after the roast that Dan went through, but some on this list might want to consider another PAKE going through an IETF working group.

HTTP-Auth is making experimental authentication mechanisms for the HTTP layer. One of those is a PAKE. If people here on the CFRG list would like to comment on it, that would be great. We can have some discussion here, but ultimately, comments criticisms and suggestions should go to the HTTP-auth list (details below).

The draft in question is called "Mutual Authentication Protocol for HTTP".

Link: http://tools.ietf.org/html/draft-ietf-httpauth-mutual-01

Yoav
co-chair of HTTP-Auth

Mailing list details:
* http-auth List Information: https://www.ietf.org/mailman/listinfo/http-auth
* http-auth List Archives: http://www.ietf.org/mail-archive/web/http-auth/current/maillist.html
* http-auth Posting Address (requires registration): [email-masked]<mailto:[email-masked]>
_______________________________________________
Cfrg mailing list
[email-masked]<mailto:[email-masked]>
http://www.irtf.org/mailman/listinfo/cfrg

--
"Those who would give up Essential Liberty to purchase a little
Temporary Safety deserve neither  Liberty nor Safety."
-- Benjamin Franklin

Email secured by Check Point

---

From: Yoav Nir <[email-masked]>
Date: Thu, 9 Jan 2014 18:57:49 +0000

Another reply

On Jan 9, 2014, at 9:25 AM, Dan Harkins <[email-masked]> wrote:

[snipped a question about where the algorithm draft was]

> 
>  Also, figure 5 seems almost like a joke. Is this protocol _really_
> that complicated? A security protocol that complicated seems like
> a recipe for disaster.
> 
>  regards,
> 
>  Dan.