Subject: [http-auth] I18N feedback on <https://trac.tools.ietf.org/html/draft-ietf-httpauth-digest-12#section-3.9.2>

From: Julian Reschke <[email-masked]>
Date: Tue, 27 Jan 2015 23:02:58 +0100

Quoting:

>    The following example assumes that an access protected document is
>    being requested from the server via a GET request.  The URI for the
>    request is "http://api.example.org/doe.json".  Both client and server
>    know the userhash of the username, support the UTF-8 character
>    encoding scheme, and use the SHA-512-256 algorithm.  The username for
>    the request is a variation of "Jason Doe" and has the byte sequence
>    4A C3 A4 73 C3 B8 6E 20 44 6F 65.  The password is "Secret, or not?".

Can we say:

> The username for the request is a variation of "Jason Doe", where the the 'a' actually is Unicode code point U+00E4 ("LATIN SMALL LETTER A WITH DIAERES"), and the first 'o' is Unicode code point U+00F8 ("LATIN SMALL LETTER O WITH STROKE"), leading to the octet sequence using the UTF-8 encoding scheme:
>
>    J  U+00E4 s  U+00F8 n      D  o  e
>    4A C3A4   73 C3B8   6E 20 44  6F 65
>
> The password is "Secret, or not?".

Best regards, Julian

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Wed, 28 Jan 2015 10:15:23 -0500

Thanks Julian,

Sure, will do that in the next version of the draft.

Regards,
 Rifaat

On Tue, Jan 27, 2015 at 5:02 PM, Julian Reschke <[email-masked]>
wrote:

>  The username for the request is a variation of "Jason Doe", where the the
>> 'a' actually is Unicode code point U+00E4 ("LATIN SMALL LETTER A WITH
>> DIAERES"), and the first 'o' is Unicode code point U+00F8 ("LATIN SMALL
>> LETTER O WITH STROKE"), leading to the octet sequence using the UTF-8
>> encoding scheme:
>>
> _______________________________________________
> http-auth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-auth
>