Subject: Re: [http-auth] MutualAuth: Looking for Volunteers

From: Yoav Nir <[email-masked]>
Date: Tue, 8 Mar 2016 21:26:05 +0200

Note: This time it’s cross-posted for real, so please don’t reply-all to this message.

Thanks to all who volunteered. It’s always great to see how much help you can get at the IETF just by asking.

Peter, Melinda and Cory volunteered first, and they will be reviewing our three documents. Other reviews are, as always, welcome

Thanks again to everyone, and especially to Peter, Melinda and Cory.

Yoav & Rifaat

On 8 Mar 2016, at 9:10 AM, Yoav Nir <[email-masked]> wrote:

> Hi all
> 
> The HTTP-Auth working group has been working on a set of three documents for
> a mutual authentication method for HTTP. These documents are:
> * draft-ietf-httpauth-mutual-06
> * draft-ietf-httpauth-mutual-algo-04
> * draft-ietf-httpauth-extension-05
> 
> The documents are feature complete. However, neither the authors nor the 
> WG chairs are native English speakers, and we would like to have the 
> language of these documents improved before proceeding to WG and IETF last
> calls. 
> 
> If anyone would like to volunteer to read one or more of these documents
> and help us improve grammar and readability, we would appreciate this very
> much. As always in the IETF, substantive comments and nits are always
> welcome as well. 
> 
> So if you're interested and are able to perform a language review on one or
> more of these documents please contact one of the chairs directly. 
> 
> Thanks in advance,
> 
> Yoav and Rifaat
> HTTP-Auth Chairs

---

From: Cory Benfield <[email-masked]>
Date: Wed, 9 Mar 2016 13:33:58 +0000

> On 8 Mar 2016, at 19:26, Yoav Nir <[email-masked]> wrote:
> 

[Removing HTTPBis and Security Area from reply]

Following up on this, I have a batch of notes for draft-ietf-httpauth-extension-05. Currently these are in list form attached to this mail: for anyone who finds the attachment has been stripped, feel free to find the notes here[0]. Mostly these notes are in the form of “for the phrase X, change to phrase Y”. Some involve basic word replacement. A few have more free-form questions or responses, when I was either not able to understand the phrase well enough to propose a replacement, or when more substantial review of a sentence might be required.

The notes are broken out by section. Each note is sequential in the section: that is, the notes are in the order of the phrases in that section. The notes are *not* broken up by subsection to avoid the nesting getting too extreme.

A very few notes say “This chunk appears in more than one place”. They always identify which section or sub-section has the same phrase recurring. The phrase should be changed in all places it appears in that section.

Please let me know if it’d be more convenient for me to make these changes against a copy of the draft and then provide my changed copy of the draft in its entirety, rather than as 300-line file!

I hope this feedback is valuable, and please let me know if you need anything else,

Cory

[0]: https://gist.github.com/Lukasa/2563d76f64a7d161335f