Subject: [http-state] domain= using protocol://

From: Daniel Stenberg <[email-masked]>
Date: Tue, 5 May 2009 23:59:52 +0200 (CEST)

Hey

Someone was having problems with a site using my software, and the site seems 
to be sending it's cookies with a domain part involving the protocol as well. 
Like in:

    Set-Cookie: PHPSESSID=6bda0; path=/fake/; domain=http://www.example.com

Just out of curiosity, does anyone around here know if user-agents out there 
actually support this? libcurl surely doesn't...

-- 

  / daniel.haxx.se

---

From: Bil Corry <[email-masked]>
Date: Tue, 05 May 2009 20:55:08 -0500

Daniel Stenberg wrote on 5/5/2009 4:59 PM: 
> Someone was having problems with a site using my software, and the site
> seems to be sending it's cookies with a domain part involving the
> protocol as well. Like in:
> 
> Just out of curiosity, does anyone around here know if user-agents out
> there actually support this? libcurl surely doesn't...

I did a quick test using Firefox 3 and IE 8; neither one appears to support it.

- Bil