Subject: [http-state] Documenting the test results

From: Bil Corry <[email-masked]>
Date: Mon, 17 Aug 2009 12:52:40 -0500

Michal Zalewski is interested in adding a summary of our various test results to the Browser Security Handbook[1].  He'd prefer to refer to a single document rather than the individual list posts.  Is someone already compiling a list of test results?  If not, I can work on it as I think it'd be helpful for historical reasons to have them compiled somewhere, especially since most of our recommendations are based on them.  Or we make it a companion document to our I-D that can be referenced for implementors.

- Bil

[1] http://code.google.com/p/browsersec/wiki/Main

---

From: Adam Barth <[email-masked]>
Date: Mon, 17 Aug 2009 11:43:32 -0700

> Michal Zalewski is interested in adding a summary of our various test results to the Browser Security Handbook[1].  He'd prefer to refer to a single document rather than the individual list posts.…

That would be great.  Let me know if you have any trouble running the
test harness.  To run all the tests at once, you'll need to be able to
build the open source browsers to grab the test binaries (TestShell,
DumpRenderTree, and TestGetURL) that we're integrating with.

Adam