Subject: [http-state] empty expires means session

From: Daniel Stenberg <[email-masked]>
Date: Tue, 13 Oct 2009 05:53:50 +0200 (CEST)

Hello

I just recently fell over a problem in my parser when it comes to expires 
without a date, like in:

    Set-Cookie: name=value; path=/; expires=

Both Firefox and IE apparently then treat this as a session cookie, as if 
there had been no expires field at all.

I just think it was worth noting, and we should probably add a test case for 
it.

-- 

  / daniel.haxx.se

---

From: Adam Barth <[email-masked]>
Date: Mon, 12 Oct 2009 21:23:45 -0700

Thanks.  I've updated the spec with this behavior.  I haven't written
a test yet.

Adam

On Mon, Oct 12, 2009 at 8:53 PM, Daniel Stenberg <[email-masked]> wrote:
> _______________________________________________
> http-state mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-state
>

---

From: Dan Witte <[email-masked]>
Date: Tue, 13 Oct 2009 10:41:35 -0700 (PDT)

More generally, in Firefox, if conversion of the "expires" attribute fails we'll fall back to making it a session cookie. I'm not sure if you have tests for cases like that, so I thought I'd mention it.

Dan

----- Original Message -----
From: "Adam Barth" <[email-masked]>
To: "Daniel Stenberg" <[email-masked]>
Cc: "HTTP-state mailing list" <[email-masked]>
Sent: Monday, October 12, 2009 9:23:45 PM GMT -08:00 US/Canada Pacific
Subject: Re: [http-state] empty expires means session

Adam

---

From: Adam Barth <[email-masked]>
Date: Tue, 13 Oct 2009 10:54:05 -0700

> More generally, in Firefox, if conversion of the "expires" attribute fails we'll fall back to making it a session cookie. I'm not sure if you have tests for cases like that, so I thought I'd mentio…

I need to elaborate the date parsing section in more details, but I've
added a note to this effect.  I haven't figured out a good way to
write date tests yet because I don't have a good way of measuring when
a cookie will expire / simulating moving the browser into the future.

Adam