Subject: [http-state] Lack of IANA Considerations

From: Julian Reschke <[email-masked]>
Date: Thu, 27 May 2010 14:33:06 +0200

Hi,

we need an IANA Considerations Section that instructs IANA to update the 
permanent header registrations for "Cookie" and "Set-Cookie".

(Adam, I'll produce the necessary spec text if you want).

Best regards, Julian

---

From: Adam Barth <[email-masked]>
Date: Thu, 27 May 2010 10:01:17 -0700

Thanks.  I'd appreciate that.

Adam

On Thu, May 27, 2010 at 5:33 AM, Julian Reschke <[email-masked]> wrote:
> _______________________________________________
> http-state mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-state
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 27 May 2010 19:45:51 +0200

> Thanks.  I'd appreciate that.

Here we go - diff relative to -08.xml:

1391a1392,1416
 >
 > <section title="IANA Considerations" anchor="iana.considerations">
 >   <t>
 >     The permanent message header registry (see <xref target="RFC3864"/>)
 >     should be updated with the following registrations:
 >   </t>
 >
 >   <section title="Cookie">
 >     <t>Header field name: Cookie</t>
 >     <t>Applicable protocol: http</t>
 >     <t>Status: standard</t>
 >     <t>Author/Change controller: IETF</t>
 >     <t>Specification document: this specification (<xref 
target="sane-cookie"/>)</t>
 >   </section>
 >
 >   <section title="Set-Cookie">
 >     <t>Header field name: Set-Cookie</t>
 >     <t>Applicable protocol: http</t>
 >     <t>Status: standard</t>
 >     <t>Author/Change controller: IETF</t>
 >     <t>Specification document: this specification (<xref 
target="sane-set-cookie"/>)</t>
 >   </section>
 > </section>
1648a1674,1684
 >       <reference anchor='RFC3864'>
 >         <front>
 >           <title>Registration Procedures for Message Header 
Fields</title>
 >           <author initials='G.' surname='Klyne' fullname='G. Klyne'/>
 >           <author initials='M.' surname='Nottingham' fullname='M. 
Nottingham'/>
 >           <author initials='J.' surname='Mogul' fullname='J. Mogul'/>
 >           <date year='2004' month='September' />
 >         </front>
 >         <seriesInfo name='BCP' value='90' />
 >         <seriesInfo name='RFC' value='3864' />
 >       </reference>