Subject: Re: [http-state] http-state Digest, Vol 13, Issue 5

From: eric bianchetti <[email-masked]>
Date: Wed, 12 May 2010 19:26:13 -0700 (PDT)

hello Adam,

my point was not about the use of SHOULD and SHOULD NOT; but was about the confusion (or potential confusion for non native english who still are the majority of the human being) to have 2 paragraphs refering to the very same problem being at different places.

Allow me to illustrate what I might suggest : 

instead of :

4.1.1.? Syntax
 .....

 Servers SHOULD NOT include two Set-Cookie header fields in the same
 ?? response with the same cookie-name.

 .....

 If a server sends multiple responses containing Set-Cookie headers
 concurrently to the user agent (e.g., when communicating with the
 user agent over multiple sockets), these responses create a "race
 condition" that can lead to unpredictable behavior.

I would suggest : 

4.1.1.? Syntax
 .....

 Servers SHOULD NOT include two Set-Cookie header fields in the same
 response with the same cookie-name.

If a server sends multiple responses containing Set-Cookie headers
 concurrently to the user agent (e.g., when communicating with the
 user agent over multiple sockets), these responses create a "race
 condition" that can lead to unpredictable behavior.

Mean the 2 paragraphs one after the other. It would increase the readability/understanding/focus of people reading the RFC , said people being non native english (as I am) . Or eventually grouping them (but it would mean some rewriting, so mean waste of precious time) into one paragraph.

I do understand that is quite nitpicking, at the same level as to argue for a missing or misplaced  coma; a cosmetic suggestion only. So if discarded I would obviously understand why. :)

Best regards

Eric

:16:46 -0700
From: Adam Barth <[email-masked]>
Subject: Re: [http-state] http-state Digest, Vol 13, Issue 4
To: eric bianchetti <[email-masked]>
Cc: [email-masked]
Message-ID:
    <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1

Sometimes people do things they shouldn't...

You might find http://www.ietf.org/rfc/rfc2119.txt helpful.

Adam

On Tue, May 11, 2010 at 7:13 PM, eric bianchetti
<[email-masked]> wrote:
> Hello,
>
> Maybe it's because my level of english; but to me both of the following sentences are contradicting (if a server SHOULD NOT do soemthing, why then speak of what might happend if they do that thing?) :
>
> 4.1.1.? Syntax
> .....
>
> Servers SHOULD NOT include two Set-Cookie header fields in the same
> ?? response with the same cookie-name.
>
>
> .....
>
> If a server sends multiple responses containing Set-Cookie headers
> ?? concurrently to the user agent (e.g., when communicating with the
> ?? user agent over multiple sockets), these responses create a "race
> ?? condition" that can lead to unpredictable behavior.
>
>
> My opinion (as not english native) is a reformulation, or even the suppression of the second sentence , would give more clarity.
>
> Best regards
>

---

From: Adam Barth <[email-masked]>
Date: Wed, 12 May 2010 20:59:43 -0700

Done.

On Wed, May 12, 2010 at 7:26 PM, eric bianchetti
<[email-masked]> wrote:
> _______________________________________________
> http-state mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-state
>