Subject: [http-state] wrt reference for netscape cookie spec

From: =JeffH <[email-masked]>
Date: Tue, 14 Sep 2010 13:35:20 -0700

I agree with Bjoern, Julian, and PeterSA that we really ought to have a more 
complete best-effort reference for the netscape cookie spec. Here's xml for that..

       <reference anchor="Netscape"
 
target="http://web.archive.org/web/20020803110822/http://wp.netscape.com/newsref/std/cookie_spec.html">
         <front>
           <title>Persistent Client State -- HTTP Cookies</title>
           <author fullname="Netscape Communications Corp.">
             <organization>
               Netscape Communications Corp.
             </organization>
           </author>
           <date year="c1999" />
         </front>
       </reference>

HTH,

=JeffH
------

applicable messages..

 > Subject: Re: [http-state] Comments on draft-ietf-httpstate-cookie-08.txt (1
 > 	- 4.1.2.)
 > From: Adam Barth <[email-masked]>
 > Date: Sun, 30 May 2010 18:58:23 -0700
 > To: Bjoern Hoehrmann <[email-masked]>
 > Cc: [email-masked]

 > ... <snip/> ...
 >
 > On Thu, May 27, 2010 at 12:49 AM, Julian Reschke <[email-masked]> wrote:
 >> On 26.05.2010 22:45, Adam Barth wrote:
 >>> On Wed, May 26, 2010 at 10:22 AM, Bjoern Hoehrmann<[email-masked]>
 >>>  wrote:
 >>>> Later in the section, there should be a bibliographic reference for the
 >>>> "Netscape cookie specification".
 >>>
 >>> I'd be happy to add this if you let me know what citation you think we
 >>> should use here.  The problem is that I don't know of a canonical URL
 >>> to cite now that the original Netscape site is defunct.
 >>
 >> I agree that this needs a citation, even if we can't provide the original
 >> URI. Proposal: create something on purl.org (I know the RFC Editor is likely
 >> to accept that), and let it redirect to the best copy we can find. If that
 >> breaks, we still can update the purl.
 >
 > I've added the citation without a URL.  There are lots of broken URLs
 > in the old cookie specs.  I don't really want to add to the sadness of
 > broken URLs.  Hopefully search engines in the future will be powerful
 > enough to find the document if it still exists.
 >
 > ... <snip/> ...

Subject: Re: [http-state] draft-ietf-httpstate-cookie-09 references
From: Peter Saint-Andre <[email-masked]>
Date: Wed, 21 Jul 2010 20:39:16 -0600 (19:39 PDT)
To: [email-masked]

On 7/16/10 8:04 PM, Bjoern Hoehrmann wrote:
 > * Julian Reschke wrote:
 >> On 14.07.2010 19:14, Adam Barth wrote:
 >>> On Wed, Jul 14, 2010 at 5:35 AM, Julian Reschke<[email-masked]>  wrote:
 >>>>    [Netscape]
 >>>>               "Persistent Client State -- HTTP Cookies".
 >
 >> In the absence of an authoritative source, it's a good service to the
 >> reader to provide a URI that actually works. In particular, as, in this
 >> case, we can be confident that the URI is going to work for a long time.
 >
 > (Publisher and a publication date would also be an improvement.)

Agreed.

I'd suggest something like this:

[Cookies] Netscape Communications, "Persistent Client State -- HTTP
Cookies (Preliminary Specification)", 1999, retrieved from
<http://web.archive.org/web/20070805052634/http://wp.netscape.com/newsref/std/cookie_spec.html>.

Peter

---

From: Adam Barth <[email-masked]>
Date: Thu, 16 Sep 2010 01:37:52 -0700

http://github.com/abarth/http-state/commit/443dfe0c943befbbf47a3713fec924a2ff0fb27d

On Tue, Sep 14, 2010 at 1:35 PM, =JeffH <[email-masked]> wrote:
> _______________________________________________
> http-state mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-state
>