Subject: Re: [http-state] wrt terminology: "request-host" and "request-uri"

From: =JeffH <[email-masked]>
Date: Fri, 17 Sep 2010 17:21:26 -0700

>> one other thing on the request-host definition occurred to me -- is it
 >> always going to be a "fully-qualified domain name" ?  I may have got that
 >> aspect of it wrong.
 >
 > We usually call this value the "host".  It's the thing that comes
 > after the scheme but before the port in the URL.

uh, yeah -- it's production in RFC3986 is "host" :)

 > It could be "www" in
 > the URL http://www/, for example.

Ok, so we have the "fully-qualified domain name"  part wrong (sorry). so 
perhaps the request-host definition should be..

    The request-host is the name of the host, as known
    by the user agent, to which the user
    agent is sending an HTTP request or is receiving an
    HTTP response from (i.e., the name of the host
    to which it sent the corresponding HTTP request).

=JeffH

---

From: Adam Barth <[email-masked]>
Date: Fri, 24 Sep 2010 18:13:11 -0700

Done.

On Fri, Sep 17, 2010 at 5:21 PM, =JeffH <[email-masked]> wrote:
> _______________________________________________
> http-state mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-state
>