Subject: Re: [http-state] [Technical Errata Reported] RFC6265 (3444)

From: =JeffH <[email-masked]>
Date: Mon, 07 Jan 2013 09:07:18 -0800

>>>>    path-value        = *av-octet
 >>>>    extension-av      = *av-octet
 >>>>    av-octet          = <any CHAR except CTLs or ";">
 > ...
 >> In which case we might want to replace the prose rule with a true ABNF
 >> production.
 >
 > Happy to go that route.  So how about this correction?:
 >
 >    path-value        = *av-octet
 >    extension-av      = *av-octet
 >    av-octet          = %x20-3A / %x3C-7E
 >                      ; any CHAR except CTLs or ";"

that looks good to me.

thanks for writing it up.

=JeffH

---

From: Adam Barth <[email-masked]>
Date: Mon, 7 Jan 2013 12:07:25 -0800

> >                      ; any CHAR except CTLs or ";"

+1

Adam

---

From: Pete Resnick <[email-masked]>
Date: Mon, 7 Jan 2013 14:18:21 -0600

On 1/7/13 2:07 PM, Adam Barth wrote:
> On Mon, Jan 7, 2013 at 9:07 AM, =JeffH<[email-masked]>  wrote:
>    
>>>>>>     path-value        = *av-octet
>>>>>>     extension-av      = *av-octet
>>>>>>     av-octet          =<any CHAR except CTLs or ";">
>>>>>>              
>>> ...
>>>        

So you want to allow space but not tab, right?

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Barry Leiba <[email-masked]>
Date: Mon, 7 Jan 2013 15:28:39 -0500

> So you want to allow space but not tab, right?

Well, that's what the current text ("any CHAR except CTLs") says.  If
we want to "fix" that, then now's the time, while we're
precisificatifying the ABNF.

So, which should it be?:

1:  av-octet = %x20-3A / %x3C-7E    (allows space, but not tab)

2:  av-octet = %x21-3A / %x3C-7E    (allows neither space nor tab)

3:  av-octet = %x09 / %x20-3A / %x3C-7E    (allows both space and tab)

Barry

---

From: Adam Barth <[email-masked]>
Date: Mon, 7 Jan 2013 12:48:13 -0800

> 3:  av-octet = %x09 / %x20-3A / %x3C-7E    (allows both space and tab)

This grammar is intentionally "loose" because there is such a wide
variety of crazy Set-Cookie headers in the world.  Allowing tab
doesn't seem harmful, so I'd recommend (3).

Adam

---

From: Julian Reschke <[email-masked]>
Date: Tue, 08 Jan 2013 03:19:18 +0100

> doesn't seem harmful, so I'd recommend (3).

Big -1.

We're now changing the spec instead of fixing an editorial bug.

If we *really* want a change, this needs way more IETF review than an 
Erratum gets.

Best regards, Julian

---

From: Adam Barth <[email-masked]>
Date: Mon, 7 Jan 2013 23:11:31 -0800

> If we *really* want a change, this needs way more IETF review than an

Fair enough.

Adam