Subject: [http-state] [Technical Errata Reported] RFC6265 (3444)

From: RFC Errata System <[email-masked]>
Date: Sun, 6 Jan 2013 14:02:49 -0800 (PST)

The following errata report has been submitted for RFC6265,
"HTTP State Management Mechanism".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6265&eid=3444

--------------------------------------
Type: Technical
Reported by: Eran Hammer <[email-masked]>

Section: 4.1.1

Original Text
-------------
path-value        = <any CHAR except CTLs or ";">
extension-av      = <any CHAR except CTLs or ";">

Corrected Text
--------------
path-value        = * <any CHAR except CTLs or ";">
extension-av      = * <any CHAR except CTLs or ";">

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6265 (draft-ietf-httpstate-cookie-23)
--------------------------------------
Title               : HTTP State Management Mechanism
Publication Date    : April 2011
Author(s)           : A. Barth
Category            : PROPOSED STANDARD
Source              : HTTP State Management Mechanism
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sun, 06 Jan 2013 23:59:22 +0100

>Original Text

(That does indeed seem incorrect.)

>Corrected Text

I would prefer if the quantifier is either pulled into the prose rule,
or the set of characters is put in a separate rule, say `av-octets`,
and the quantifier is then put in front of the reference to the rule.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Barry Leiba <[email-masked]>
Date: Mon, 7 Jan 2013 09:23:53 -0500

> and the quantifier is then put in front of the reference to the rule.

I'm having trouble parsing all that.  Can you give a specific
alternative update that you think is better?

Barry

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 07 Jan 2013 15:38:49 +0100

>alternative update that you think is better?

Something like

  path-value        = *av-octet
  extension-av      = *av-octet
  av-octet          = <any CHAR except CTLs or ";">

Or

  path-value        = <zero or more of: any CHAR except CTLs or ";">
  extension-av      = <zero or more of: any CHAR except CTLs or ";">

For instance.

---

From: Barry Leiba <[email-masked]>
Date: Mon, 7 Jan 2013 09:49:46 -0500

>   extension-av      = <zero or more of: any CHAR except CTLs or ";">

The second is really a non-starter: we want to minimize the plaintext
instructions and put as much as possible in actual ABNF syntax.

The first seems fine, but why do you think it's better than what the
errata suggests?  I don't seen any advantage (or disadvantage) either
way.

Barry

---

From: Julian Reschke <[email-masked]>
Date: Mon, 07 Jan 2013 16:42:46 +0100

> instructions and put as much as possible in actual ABNF syntax.

In which case we might want to replace the prose rule with a true ABNF 
production.

> errata suggests?  I don't seen any advantage (or disadvantage) either

I agree with Björn that combining <prose rules> with "*" is something we 
should avoid.

Best regards, Julian

---

From: Barry Leiba <[email-masked]>
Date: Mon, 7 Jan 2013 11:17:10 -0500

>>>    av-octet          = <any CHAR except CTLs or ";">
...
> In which case we might want to replace the prose rule with a true ABNF

Happy to go that route.  So how about this correction?:

   path-value        = *av-octet
   extension-av      = *av-octet
   av-octet          = %x20-3A / %x3C-7E
                     ; any CHAR except CTLs or ";"

Any objections?

Barry

---

From: Pete Resnick <[email-masked]>
Date: Mon, 7 Jan 2013 08:56:13 -0600

On 1/7/13 8:49 AM, Barry Leiba wrote:
>>>>> Corrected Text
>>>>> --------------
>>>>> path-value        = *<any CHAR except CTLs or ";">
>>>>> extension-av      = *<any CHAR except CTLs or ";">
>>>>>            
>>    av-octet          =<any CHAR except CTLs or ";">
>>
>> Or
>>
>>    path-value        =<zero or more of: any CHAR except CTLs or ";">
>>    extension-av      =<zero or more of: any CHAR except CTLs or ";">
>>      

I tend to agree with Bjoern on this one. Though having a repeat before a 
prose-val is legal in ABNF, I find it pretty distasteful. Then again, I 
find prose-val in general to be distasteful. And I'm not clear on why 
you think the second suggestion above is a non-starter. Once we've gone 
and used prose-val, what harm is there in fixing the currently incorrect 
prose-val rather than adding a repeat to the front of it?

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 07 Jan 2013 20:26:10 +0100

>errata suggests?  I don't seen any advantage (or disadvantage) either

It seems strange and confusing to me to mix the informal prose with the
formal ABNF syntax; I rather think of them as

  placeholder = <this rule is not expressed in ABNF here>

so I expect the right-hand side to either be only a prose value or to be
free of prose values. I am not aware of encountering counter-examples in
the wild (except being confused by RFC 3986's `path-empty = 0<pchar>`).
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Pete Resnick <[email-masked]>
Date: Mon, 28 Jan 2013 10:26:40 -0600

Getting back to an earlier conversation:

>                       ; any CHAR except CTLs or ";"

I've edited the erratum to put the above into the "Note". See:

I personally find the "* <free text>" thing distasteful, but that's 
because I find the free text distasteful in the first place. I figure 
this way, we've got the simple correction that makes the ABNF correct, 
and a note with a more involved change that makes it clear.

Does that work for folks?

pr

---

From: Julian Reschke <[email-masked]>
Date: Mon, 28 Jan 2013 17:41:17 +0100

> Does that work for folks?

Works for me (and I agree with the Note).

Best regards, Julian