Subject: RE: Host header issue

From: "Larry Masinter" <[email-masked]>
Date: Tue, 7 Sep 1999 16:41:02 PDT

You know, I'm still not sure under which situation you
would 

a) not require a Host: header to be sent by a client;
   (since there are HTTP/1.1 servers that would error
   if the Host header were omitted)

b) not require that a server respond with an error if the Host
  header were missing (since HTTP/1.1 clients should only
  send absolute URIs to proxies.)

Procedurally, since HTTP/1.1 is Draft Standard, the only way
I can think to institute a change such as this would be to write
a separate document, as Proposed Standard, which updates 2616;
I'd suggest:

   Omitting Host Header from HTTP/1.1 Requests with Full URI

as a title.

Note that:

   1. If Request-URI is an absoluteURI, the host is part of the
     Request-URI. Any Host header field value in the request MUST be
     ignored.

so a valid request would be

GET http://host.dom/path HTTP/1.1
Host: 

and you're saving 7 bytes for the "CRLFHost:" But then, if you're so
concerned about saving 6 bytes, why not also work on encoding the 20 bytes
that comprise "GET http://" and "HTTP/1.1" into something more efficient?

Larry
-- 
http://www.parc.xerox.com/masinter

---

From: "Josh Cohen (Exchange)" <[email-masked]>
Date: Tue, 7 Sep 1999 15:42:53 -0700

> -----Original Message-----
> From: John Stracke [mailto:[email-masked]]
> Sent: Tuesday, September 07, 1999 11:30 AM
> To: [email-masked]
> Subject: Re: Host header issue
> 
> This isn't necessarily pathological.  My home network 
> includes a proxy; it runs
> Apache with mod_proxy, and that same Apache also serves up 
> its own content.  It
> has two CNAMEs, "proxy" and "www"; my browser is configured 
> to use "proxy" as
> its proxy.  So, if I send my browser to http://www/foo.html, 
> then Apache gets a
> request whose request-URI is http://www/foo.html.  It knows 
> that www is itself,
> so it delivers its own content.
>
In which case you really dont need the Host: header...
hence my point..

> --
> /============================================================\
> |John Stracke    |http://www.ecal.com|My opinions are my own.|
> |Chief Scientist |===========================================|
> |eCal Corp.      |"Who died and made you king?" "My father." |
> [email-masked]|                                           |
> \============================================================/
> 
>