Subject: RE: Https proxies - was Re: http proxy & tunnel differences ??

From: "Scott Lawrence" <[email-masked]>
Date: Tue, 26 Oct 1999 17:28:18 -0400

> From: [email-masked]

> This looks like an opportunity to expand my understanding
> on https proxies as well. When a client issues a CONNECT
> request to a proxy, the proxy creates a connection to
> the remote site, and the proxy returns an HTTP 200
> response to the client. From that point, the client
> and remote site exchange data through the proxy. My
> question is what is that data? Does the client have to
> issue a full SSL handshake over the connection, or can
> the client just send data. In other words, what happens
> after the CONNECT from a client's perspective.

CONNECT really just asks a proxy to create the origin server connection
and then switch to tunnel mode for the pair of connections
(client-proxy, proxy-origin).  What the client does over it is up to the
client.  Usage of CONNECT is not limited to https; for https you must
begin with the handshake.
--
Scott Lawrence           Director of R & D        <[email-masked]>
Agranat Systems, Inc.  Embedded Web Technology   http://www.agranat.com/

---

From: [email-masked]
Date: Tue, 26 Oct 1999 19:10:14 +0100 (BST)

Regards,
Doug
--
-----------------------------------------------------
Doug Reed	
mailto:[email-masked]
-----------------------------------------------------	
> >> A proxy works by taking a request from a client and
> >> connecting to the origin
> >> server indicated in the request.  Here the client is configured to go
> >> through the proxy.
> >
> >Actually, the client may or may not know about the proxy.
> 
> The client always knows about the proxy -- that is what distinguishes
> a proxy from a gateway.  A "reverse proxy" is a gateway.
> 
> >> How does a http tunnel work. Is the initial connection similar ?
> >> Does a client (browser) need to configured differently when
> >> it goes through
> >> a tunnel or is it same as the configuration required when it
> >> goes through
> >> the proxy ? Are there to separate tcp connections for each
> >> request even in a
> >> tunnel ?
> 
> Some tunnels are activated by a proxy request, some are simply
> port forwarding TCP firewalls (either on the client side or the
> server side, or both), and others are gateways to other servers.
> The important thing from HTTP's perspective is that once an
> intermediary becomes a tunnel, it is no longer conscious of the
> HTTP communication -- only of bytes being relayed from one connection
> to another.
> 
> ....Roy
>