Subject: RE: Microsoft HTTP 1.1 Conformance?

From: Josh Cohen <[email-masked]>
Date: Thu, 13 Apr 2000 10:49:37 -0700

Our proxy server also has support for http/1.1.

> -----Original Message-----
> From: Keith Hoffman [mailto:[email-masked]]
> Sent: Thursday, April 13, 2000 9:56 AM
> To: Scott Lawrence; John C. Mallery
> Cc: [email-masked]
> Subject: Re: Microsoft HTTP 1.1 Conformance?
> 
> 
> And what about http 1.1 proxying?
>  That is supported too.  Look under the advanced options tab 
> for Internet
> properties
> 
> ----- Original Message -----
> From: "John C. Mallery" <[email-masked]>
> To: "Scott Lawrence" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, April 12, 2000 10:38 AM
> Subject: RE: Microsoft HTTP 1.1 Conformance?
> 
> 
> > At 10:06 -0400 04-12-2000, Scott Lawrence wrote:
> > > > From: John C. Mallery
> > >
> > >> I'm wondering if the microsoft browsers are going
> > >> backwards on http 1,1
> > >> conformance, just as they lost digest authentication from
> > >> IE 3 in later
> > >> releases.
> > >
> > >No, I believe that they just changed the configurability of it.
> > >
> > >IE5 supports 1.1, and supports Digest (rfc2617).
> >
> > And what about http 1.1 proxying?
> >
> >
>

---

From: "John C. Mallery" <[email-masked]>
Date: Fri, 14 Apr 2000 10:42:37 -0500

>Our proxy server also has support for http/1.1.

I can't find anywhere to turn it on for the Mac IE 5.0 Browser.
They seem to have lost the switch.  I know there is a switch for
windows.

BTW, are there reasons why http 1.1 proxying would not be the default
for the IE client?

---

From: "David W. Morris" <[email-masked]>
Date: Fri, 14 Apr 2000 11:49:48 -0700 (PDT)

> BTW, are there reasons why http 1.1 proxying would not be the default

How about providing users who have no control over the protocols
suppported by their firewall proxy with a reliable experience? I'm fairly
certain that any IT organization which chooses can use the IEAK (Admin
Kit) to build a locally configured IE variant which would have a different
default suitable for the proxy provided by that organization.

Dave Morris

---

From: "Keith Hoffman" <[email-masked]>
Date: Fri, 14 Apr 2000 16:25:14 -0500

IE on Mac doesn't have that option.  I'm not sure why that decision was
made. I believe it does HTTP 1.1 all of the time (even through proxies).

It's not the default for the IE client because there are very few proxies
that are truly and fully HTTP 1.1 compliant.  Most are actually a mix - http
1.0.5 if you will. :)    Having HTTP 1.1 through the proxy turned off by
default helps avoid port negotiation issues on some proxies.

---

From: "John C. Mallery" <[email-masked]>
Date: Fri, 14 Apr 2000 18:17:35 -0500

>made. I believe it does HTTP 1.1 all of the time (even through proxies).

No testing with my proxy should IE 5.0 for the Mac makes 1.0 proxy requests
even though it makes 1.1 requests when no proxy is specified.

One of the major intentions of http 1.1 was to clean up http proxying,
and yet......