Subject: IPV6 address in host header, needs clarification

From: "Larry Masinter" <[email-masked]>
Date: Mon, 17 Apr 2000 17:34:08 -0700

Following RFC 2732 & integrating with HTTP 1.1:

> > The problem I have is in the Host field in the HTTP 1.1 header
> > 
> > It says:
> > 
> > Host hostname
> > 
> > or
> > 
> > Host hostname:port
> > 
> > If hostname is an IPv6 literal address, then there is an ambiguity due
> > the colon
> > 
> > example:
> > 
> > Host 3ffe::1:8080
> > 
> > Does this mean hostname is 3ffe::1 and port 8080 or hostname
> > 3ffe::1:8080 and default port 80 ?
> > 
> > The only way to remove the ambiguity is to make the use of [ ] around
> > the IPv6
> > literal address madatory. Such as:
> > 
> > Host [3ffe::1]:8080
> > 
> > or
> > 
> > Host [3ffe::1:8080]
> > 
> > 
> > We ran into this problem at Connectathon 2000.

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 17 Apr 2000 17:53:24 -0700

What useful purpose does sending an IP (v anything) address in
a Host header field perform?

....Roy

---

From: Zachary Amsden <[email-masked]>
Date: Mon, 17 Apr 2000 18:05:47 -0700

This was the solution recommended at IETF-47.  Of course, you also have the 
problem with userland utilities that accept host:port designations as well.

-- 
Zachary Amsden  [email-masked]  3-6919  31-2-510  Core Protocols

---

From: Marc Slemko <[email-masked]>
Date: Mon, 17 Apr 2000 18:59:55 -0600 (MDT)

> a Host header field perform?

Being able to make a HTTP/1.1 request at all using an IP address... since
you need a Host: header of some sort.

And it is definitely useful or even necessary to allow requests using an
IP address.  But that is another debate that comes up over and over in
general, especially with IPv6...

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 17 Apr 2000 18:23:45 -0700

>you need a Host: header of some sort.

That's not what I meant.  Is this just a question about what to put
in the field value, or is there some functionality/semantics desired
behind the server interpreting this value (which we have discussed
in the past as being a bad thing).

The syntax for host is defined by reference to RFC 2396, which in
turn is updated by the IPv6-within-URI specification (RFC 2732),
so the answer for HTTP syntax has already been defined.

....Roy