Subject: CRLF on POST requests, where/how specified (repost from prior bad subject line)

From: "Brad Taylor" <[email-masked]>
Date: Tue, 20 Jun 2000 11:57:35 -0500

06/20/2000 11:57 AM
Brad Taylor@NEON
Brad Taylor@NEON
Brad Taylor@NEON
06/20/2000 11:57 AM
06/20/2000 11:57 AM

We are having a debate on browser behaviour and are trying to find what the
official spec says.  What we see is that browsers (ie5.0 and netscape) when
"POST"ing to our server construct a content-length and then append a 0d0a
to the end.  This 0d0a is not contained in the content length.  Is this
according to "SPEC"?  If so would someone be so kind as to point it out (I
am somewhat new to reading these specs).  Is this only going to occur for
POSTed data or will it also occur for other requests (GET, PUT,
etc.)....your consideration in advance is appreciated.

---

From: "Scott Lawrence" <[email-masked]>
Date: Tue, 20 Jun 2000 13:36:45 -0400

See RFC 2616 ( http://www.innosoft.com/rfc/rfc2616.html#sec-4.1 )

Quoting:

----
Request (section 5) and Response (section 6) messages use the
generic message format of RFC 822 [9] for transferring entities (the
payload of the message). Both types of message consist of a
start-line, zero or more header fields (also known as "headers"), an
empty line (i.e., a line with nothing preceding the CRLF) indicating
the end of the header fields, and possibly a message-body.

        generic-message = start-line
                          *(message-header CRLF)
                          CRLF
                          [ message-body ]
----
The CRLF that separates the headers from the body is not part of
either.  Since it is not part of the body, it is not included in the
content length.

--
Scott Lawrence      Director of R & D        <[email-masked]>
Agranat Systems   Embedded Web Technology   http://www.agranat.com/