Subject: Re: problem with responses to post-requests

From: "Fred Bohle" <[email-masked]>
Date: Fri, 25 Aug 2000 08:26:43 -0500

Fred Bohle@NEON
08/25/2000 08:26 AM

Olli,
     You didn't mention http version in the browsers.  If Netscape
is using 1.0 and IE is using 1.1, you may have a problem with omitting
the Connection: header.  I suggest adding a header line with

Connection: close

to tell the browser that you are closing the connection.  The addition of
a shutdown() call would help too.

     When all else fails, read the RFCs 1945 and 2616, available
from www.ietf.org.  Reading the Apache source code is useful too.

Fred

[email-masked] on 08/25/2000 05:32:15 AM

To:   [email-masked]
cc:    (bcc: Fred Bohle/Dev/Neon)

Subject:  problem with responses to post-requests

i've got a problem while responding to POST requests.

i'm currently developing a small http-server to configure some files via a
webbrowser.

while sending responses to GET requests everything works fine and the
browser prints the output. but if i try to handle a post request i
encounter
different reactions by netscape navigator and internet explorer.

after processing the content of the post-request i'm sending the
html-output to the client and close the connection. this works fine with
NN. but IE
doesn't show the page and gives an error-msg telling me that the connection
has been reset.

i just don't get it why NN is doing fine and IE not.

what's the difference between responses to GET and POST requests ?

why is IE telling me errors and not showing the transmitted page ?

greetings,
olli

here's some of the code:

while ((conn = accept(sock,(struct sockaddr *) &addr,&addr_length)) >= 0)
{
 /*
  reading/parsing header etc.
 */

if (strcmp(request->method,"POST") == 0)
{
 putsock(conn,"HTTP/1.0 200 OK\n");
 putsock(conn,"Content-Type: text/plain\n\n");
 putsock(conn,"Netscape Navigator shows this.\
              Internet Explorer gives error");
}

// here NN says "Document Done" and shows the page
// but IE gives error msg "Connection Reset"
close(conn);
}

--
Sent through GMX FreeMail - http://www.gmx.net

---

From: "Keith Hoffman" <[email-masked]>
Date: Fri, 25 Aug 2000 21:01:52 GMT

do you have a test site where I could see this and also do you have any 
network traces of the problem?  I'd like to see if there is a problem with 
the way IE handles this.

>From: [email-masked]
>Date: Fri, 25 Aug 2000 12:32:15 +0200 (MEST)
>

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com