Subject: Http overhead

From: Patrik Carlsson <[email-masked]>
Date: Thu, 30 Nov 2000 10:31:01 +0100

Hi!

I am currently working with a traffic model for an IP network. I have a
question about the amount of overhead involved when transfering binary
files over http. As fas as I understood, http handles binary files so no
encoding has to be performed (as for example files over SMTP uses MIME).
So, how many header-bytes does http add in each packet when sending a
binary file from a server to a client?

I hope someone can help me with this.

Thanks,
Patrik

---

From: Patrik Winroth <[email-masked]>
Date: Thu, 30 Nov 2000 11:32:19 +0100 (CET)

> binary file from a server to a client?

Depends on the server, but typically around 256 bytes.
E.g. this instance of Apache response uses 279 bytes:

ab -v 4 http://www.foo.com:81/poweredby.png

HTTP/1.1 200 OK
Date: Thu, 30 Nov 2000 10:21:44 GMT
Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) PHP/3.0.15 mod_perl/1.21
Last-Modified: Wed, 01 Mar 2000 18:37:44 GMT
ETag: "33303-482-38bd6378"
Accept-Ranges: bytes
Content-Length: 1154
Connection: close
Content-Type: image/png

<1154 bytes of binary data>

Cheers,

/Patrik.

--
Patrik Winroth                          <[email-masked]>