Subject: IPv6 and HTTP (1.2?)

From: "Thomas McLaren" <[email-masked]>
Date: Tue, 28 Nov 2000 11:51:39

Can anyone specify the requirements that IPv6 will have for changes to HTTP 
1.1, apart from URL structure?
_____________________________________________________________________________________
Get more from the Web.  FREE MSN Explorer download : http://explorer.msn.com

---

From: Scott Lawrence <[email-masked]>
Date: Tue, 28 Nov 2000 08:55:35 -0500

Thomas McLaren wrote:

> Can anyone specify the requirements that IPv6 will have for changes to 
> HTTP 1.1, apart from URL structure?

There aren't any - there is already a spec (sorry, don't have the 
reference handy) on how to write an IPv6 address in a URL.

-- 
Scott Lawrence      Architect            [email-masked]
Virata       Embedded Web Technology    http://www.emweb.com/

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Tue, 28 Nov 2000 17:37:48 +0100

That is quite simple and already discussed in the WG.

the standard IPv6 address specifies an IPv6 address. Because there are
always more than one ":", you know it's IPv6.
e.g. "fe80::01" or "fe80::3a3c:2bc:96f5:1060"

If you specify a port, you must send the IPv6 address as:
"[" IPv6-address "]:" port

e.g. "[fe80::01]:8080" or "[fe80::3a3c:2bc:96f5:1060]:81"

So the URL is:

e.g. "http://fe80::01/" or "http://[fe80::3a3c:2bc:96f5:1060]:81/"

for the rest nothing changes. The server (or gateway) just has to
reqognise these addresses...

Please correct me if I'm wrong.....
Send to the WG directly (no CC please), can take a while...

- Joris

> -----Original Message-----
> From: Scott Lawrence [mailto:[email-masked]]
> Sent: Tuesday 28 November, 2000 14:56
> To: Thomas McLaren
> Cc: [email-masked]
> Subject: Re: IPv6 and HTTP (1.2?)
> 
> 
> Thomas McLaren wrote:
>

---

From: "Larry Masinter" <[email-masked]>
Date: Tue, 28 Nov 2000 09:15:15 -0800

In Proposed Standard RFC 2732, IPv6 URLs must always have the
address enclosed in square brackets, whether or not a port
is supplied.

---

From: "Tom McLaren" <[email-masked]>
Date: Tue, 28 Nov 2000 17:36:56 -0000

How about priority information though? Am I correct in assuming that it will
be specified by the individual application, and is therefore outside of the
scope of HTTP?

- Tom

<previous message follows>

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Wed, 29 Nov 2000 13:46:10 +0100

As far as I know is there no specification that handles this for HTTP.

- Joris

> From: Tom McLaren [mailto:[email-masked]]
> Sent: Tuesday 28 November, 2000 18:37
> To: HTTP Working Group
> Subject: RE: IPv6 and HTTP (1.2?)
> 
>