Subject: http over udp?

From: "Tapan Divekar" <[email-masked]>
Date: Fri, 01 Jun 2001 18:20:12 -0000

has anyone tried to use http over udp.
i have a device which has only udp type server sockets. it doenst have TCP 
ones.
I want to reach that device using netscape/ IE (any browser).
since HTTP is based over TCP , my UDP listener at my device's end wont 
receive packets sent over netscape.

Any ideas?
Thanks
Tapan
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Mon, 4 Jun 2001 16:42:23 +0200

The issue is that HTTP needs a connection-oriented transport.
Using UDP would mean that you need some sort of connection-management...

So why use UDP?

Note that UDP is a complete different protocol than TCP, even if they have
the same range of port numbers (and have ports).

- Joris

-----Original Message-----
From: Tapan Divekar [mailto:[email-masked]]
Sent: Friday, 01 June 2001 20:20
To: [email-masked]
Subject: http over udp?

Any ideas?
Thanks
Tapan

---

From: Fred Douglis <[email-masked]>
Date: Mon, 04 Jun 2001 11:53:35 -0400

A few people have investigated the use of HTTP over UDP rather than TCP, 
useful for short files as a way of bypassing TCP startup overheads.  The most 
recent such work of which I'm aware was in the last Infocom.  See

http://www.research.att.com/~misha/dhttp/abstract.html
 
Fred