Subject: re: problem with chunked encoding in http1.1

From: "Nathan J. Yoder" <[email-masked]>
Date: Thu, 5 Jul 2001 13:48:39 -0400

Ignore the second part of the last message, I didn't read the full response
in one of the e-mails.  That's right, chunked transfer enocoding is good for
messages of indeterminate length (like CGI generated responses), else it
would require caching the message in memory before sending (to determine the
length).

---

From: Patrick McManus <[email-masked]>
Date: Thu, 5 Jul 2001 14:04:26 -0400

chunked is also required on any message that has any transfer-encoding
other than chunked or identity (e.g. gzip). This removes ambiguity of
whether content-length refers to the encoded or unencoded
entity. 

-P

[Nathan J. Yoder: Thu, Jul 05, 2001 at 01:48:39PM -0400]