Subject: doubt regarding http 1.1

From: "manish kumar" <[email-masked]>
Date: Mon, 02 Jul 2001 10:12:20 -0000

Hi
I am using http 1.1.I am making a persistent connection from java client to 
apache server.I am able to make it but I don't want to use transfer encoding 
as chunked(which is there by default).Is there any way I can do it.Where I 
need to change it.If you need some more detail please let me know.

-Manish
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Mon, 2 Jul 2001 13:16:46 +0200

Why not use it? It provided a way to keep the connection open.

You can try Tranfer-Encoding: identify
see RFC2616 par. 14.41

There is also something with TE (par. 14.39).

Note that Apache will need to cache the response before transmitting it, to
demitrade the length. I don't know wether they do or support that (probably
they do). It requires only an enormous ammount of overhead on the server,
not caused with chunked transfers. So why not use these, it's simple to
build some support for that.

Before to forget, RFC2616 lists enough information in the sections with
tranfer-codings and such....

Have fun...

- Joris

>-----Original Message-----
>From: manish kumar [mailto:[email-masked]]
>Sent: Monday, 02 July 2001 12:12
>To: [email-masked]
>Subject: doubt regarding http 1.1
>
>
>Hi

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 2 Jul 2001 11:34:18 -0700

I'd echo Joris' question as to why in the world you'd want to disable
chunking, but...

<shamless_plug>
http://www.mnot.net/cgi_buffer/

Buffers Perl, Python and PHP scripts; also can act as a wrapper for
arbitrary code. Intended to be useful for 1.0 content, and for
servers that don't chunk generated objects (most don't), but it
should be helpful here.
</shameless_plug>

I think there are also Apache modules, etc. that may do this, look
at http://modules.apache.org/

-- 
Mark Nottingham
http://www.mnot.net/

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Tue, 17 Jul 2001 16:18:39 +0200

>From: Mark Nottingham [mailto:[email-masked]]
>Sent: Monday, 02 July 2001 8:34
>To: Joris Dobbelsteen
>Cc: WWW WG (E-mail)
>Subject: Re: doubt regarding http 1.1
>
>
>

HTTP/1.0 doesn't support chunking, nor persistent connections (yes, there
are some extensions, but the origional spec doesn't support it). This way,
ending a response is done by closing the connection.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Jul 2001 08:01:38 -0700

Yes, they're extensions, but all widely-used 1.0 implementations use
them, to the best of my knowledge. More to the point, many "1.1"
server implementations won't chunk some content, depending on how the
entity is generated, leading them to close the connection.
Conversely, if the generation engine supplies them with a
Content-Length header, they not only will not close the connection,
they won't chunk it, giving the desired effect.

-- 
Mark Nottingham
http://www.mnot.net/