Subject: Re: doubt regarding http 1.1

From: "manish kumar" <[email-masked]>
Date: Thu, 05 Jul 2001 12:21:32 -0000

Thanks for the response.It really helped in clearing some of the doubts.I am 
now having one more problem.I am using java socket and my server is apache.I 
am using http 1.1 ..I am having a problem with server closing the 
connection.Basically I want to have some way for server to send a message 
whenever its closing the connection.Is there any way it can be 
handled.Basically I want to differenciate between the case when server 
closes the existing socket(Only particular socket is not valid) and when 
server is down(No socket will work).

>From: Mark Nottingham <[email-masked]>
>To: Joris Dobbelsteen <[email-masked]>
>CC: "WWW WG (E-mail)" <[email-masked]>
>Subject: Re: doubt regarding http 1.1
>Date: Mon, 2 Jul 2001 11:34:18 -0700
>
>
>I'd echo Joris' question as to why in the world you'd want to disable
>chunking, but...
>
><shamless_plug>
>http://www.mnot.net/cgi_buffer/
>
>Buffers Perl, Python and PHP scripts; also can act as a wrapper for
>arbitrary code. Intended to be useful for 1.0 content, and for
>servers that don't chunk generated objects (most don't), but it
>should be helpful here.
></shameless_plug>
>
>I think there are also Apache modules, etc. that may do this, look
>at http://modules.apache.org/
>
>
>
>On Mon, Jul 02, 2001 at 01:16:46PM +0200, Joris Dobbelsteen wrote:
> > Why not use it? It provided a way to keep the connection open.
> >
> > You can try Tranfer-Encoding: identify
> > see RFC2616 par. 14.41
> >
> > There is also something with TE (par. 14.39).
> >
> > Note that Apache will need to cache the response before transmitting it, 
>to
> > demitrade the length. I don't know wether they do or support that 
>(probably
> > they do). It requires only an enormous ammount of overhead on the 
>server,
> > not caused with chunked transfers. So why not use these, it's simple to
> > build some support for that.
> >
> > Before to forget, RFC2616 lists enough information in the sections with
> > tranfer-codings and such....
> >
> >
> > Have fun...
> >
> > - Joris
> >
> > >-----Original Message-----
> > >From: manish kumar [mailto:[email-masked]]
> > >Sent: Monday, 02 July 2001 12:12
> > >To: [email-masked]
> > >Subject: doubt regarding http 1.1
> > >
> > >
> > >Hi
> > >I am using http 1.1.I am making a persistent connection from
> > >java client to
> > >apache server.I am able to make it but I don't want to use
> > >transfer encoding
> > >as chunked(which is there by default).Is there any way I can
> > >do it.Where I
> > >need to change it.If you need some more detail please let me know.
> > >
> > >-Manish
> > >_______________________________________________________________
> > >__________
> > >Get Your Private, Free E-mail from MSN Hotmail at
> > http://www.hotmail.com.
> >
> >
>
>--
>Mark Nottingham
>http://www.mnot.net/
>

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Tue, 17 Jul 2001 16:18:37 +0200

>Sent: Thursday, 05 July 2001 2:22
>To: [email-masked]; [email-masked]
>Cc: [email-masked]

Servers (most/some/dunno) will send the "Connection: Close" header when they
close the connection directly after a response.
After some time (idle time-out) servers close connections in order to save
bandwidth and clean-up connection that are no longer used, you probably
don't need them anyway.

HTTP/1.x has no method to inform about closing a inactive connection. You
will just notice the connection has been closed.
If the server is down, you can't connect to the server...

- Joris

http://www.hotmail.com.