Subject: Re: Http requirements

From: [email-masked]
Date: Tue, 30 Oct 2001 09:39:55 +0000

Hi,

I too am interested in any information about conformance test suites for
HTTP/1.1.  I've recently been involved in a client implementation, and
found planning the conformance testing a very manual task, mainly because I
could locate no resource other than the RFC that listed (in brief!) which
RFC MUST/SHOULD clauses apply to each class of application.

It's interesting to contrast this with the WAP Forum's conformance
specifications, which are found at the end of each of their specs.
Furthermore there's a test suite produced and administered by OpenGroup.org
which tests clients against each clause.  I'd be very happy to discover
that an organisation somewhere has produced a similar HTTP/1.1 client
conformance suite.

Paul Hadfield

Software Engineer
Browser Technologies
Symbian Ltd.
http://www.symbian.com/

                    Matt Lynch                                                                                                                       
                    <Matt@stimulussolutio       To:     [email-masked]                                                                    
                    ns.com.au>                  cc:                                                                                                  
                                                Subject:     Http requirements                                                                       
                    30/10/01 01:03                                                                                                                   

G'day all,
           I'm just getting to the end of an http implementation, and am in
testing for conformance to the spec.  I've interpreted the spec to the best
of my ability, and I'd like to cross reference this list against another.
Does anyone know the url to a document summarising the spec?  This seems
like such an academic exercise, I figured that there would be an .edu site
with this info...

Matt Lynch
Developer
Stimulus Solutions
http://www.stimulussolutions.com.au

**********************************************************************
Symbian Ltd is a company registered in England and Wales with registered number 01796587 and registered office at 19 Harcourt Street, London, W1H 4HF, UK.
This message is intended only for use by the named addressee and may contain privileged and/or confidential information. If you are not the named addressee you should not disseminate, copy or take any action in reliance on it. If you have received this message in error please notify [email-masked] and delete the message and any attachments accompanying it immediately. Symbian does not accept liability for any corruption, interception, amendment, tampering or viruses occurring to this message in transit or for any message sent by its employees which is not in compliance with Symbian corporate policy.
**********************************************************************

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Oct 2001 20:54:07 -0800

FYI:

This is discussed (somewhat sporadically) at:
  http://groups.yahoo.com/group/http-compliance/
and is also of some interest on the W3C's w3c-qa mailing list.

(not to say that it is or isn't appropriate here as well)

Cheers,

-- 
Mark Nottingham
http://www.mnot.net/