Subject: How to make my application a server?

From: "Viet Thang" <[email-masked]>
Date: Wed, 30 Jan 2002 16:56:35 +0700

Hi all,
I don't know it is a suitable group to ask you this question. But I hope someone of you can help me.
In my application I would like to accept request from a web browser, process it upon the link and do something, for example  show a form, a message to user at server ( not to browser- it sends browser nothing). 

All ideas are appreciated 

thanks in advance!

---

From: Rob J Meijer <[email-masked]>
Date: Wed, 30 Jan 2002 14:43:22 +0100 (CET)

> All ideas are appreciated 

This flow seems flawed.
You either:

* Talk with the browser by letting your application be a simple webserver
  (probably on some non standard port)
Or:
* Put a small CGI on the server that proccesses the reqests from the
  client/browser, from this creates a request (for example a rpc call) to
  your application using whatever protocol you like (sunrpc,sysV IPC,
  XML-RPC, SOAP or whatever taste of IPC you, or the enviroment you wrote
  your application in is most comfortable with). Your application
  responds to the cgi, and the cgi processes your response and sends
  a suitable response to the client/browser.

In many cases making your application into a UDP based server on the same
host as the server (making UDP a reliable protocol what it otherwise is
not), and having a simple cgi (or server module if you expect heavy 
loads) convert the client's requests into simple UDP based request, and
converting the responses of your application in order to respond to the client.

Hope this helps.

Rob

---

From: "Viet Thang" <[email-masked]>
Date: Thu, 31 Jan 2002 13:58:09 +0700

hi,
thanks for all your comments!
My application could not act as a server in the way we can use the server side script on it. Rob j Meijer's first solution seems rather suitable. Yes, that is really what I want to become my app. become.
It doesn't matter I listen to browser on what port, but I must parse the request from browser, Could you tell me more clearly about it?

Thanks!!!