Subject: [httpapi] Martin Duke's Block on charter-ietf-httpapi-00-00: (with BLOCK)

From: Martin Duke via Datatracker <[email-masked]>
Date: Tue, 08 Sep 2020 08:59:18 -0700

Martin Duke has entered the following ballot position for
charter-ietf-httpapi-00-00: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-httpapi/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I certainly support creation of a working group of this nature; however, from
the charter I have no idea what portion of this large problem space constitutes
the short-term objectives of this group.

---

From: Barry Leiba <[email-masked]>
Date: Thu, 10 Sep 2020 12:31:22 -0400

The -00-01 version of the proposed charter includes Mark's latest
edits.  Martin, will you check it and let us know what you think?

---

From: Martin Duke <[email-masked]>
Date: Thu, 10 Sep 2020 10:25:42 -0700

I'm in the same boat as Alissa. I can live with this is a provisional
standing WG that takes whatever comes in, for now, but if there's a
probation period it should be in the charter.

---

From: Barry Leiba <[email-masked]>
Date: Thu, 10 Sep 2020 13:28:26 -0400

> I'm in the same boat as Alissa. I can live with this is a provisional standing WG that takes
> whatever comes in, for now, but if there's a probation period it should be in the charter.

What do the two of you think about a provision to review the charter
and WG progress annually, at each year's 3rd IETF meeting?

Barry

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 10 Sep 2020 13:40:46 -0400

WFM

> On Sep 10, 2020, at 1:28 PM, Barry Leiba <[email-masked]> wrote:
>

---

From: Martin Duke <[email-masked]>
Date: Thu, 10 Sep 2020 10:41:08 -0700

If that's in there, I would remove my BLOCK.

However, I wonder why we wouldn't just hold a WG forming BOF to figure out
what they're going to do, rather than form the WG and then figure out the
initial objectives. The latter has the same first meeting while also having
less organizational overhead.

On Thu, Sep 10, 2020 at 10:28 AM Barry Leiba <[email-masked]>
wrote:

> standing WG that takes

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Sep 2020 18:22:14 +0000

It seems prohibitively hard to do a virtual BoF, based on what I’ve seen. YMMV.

---

From: Barry Leiba <[email-masked]>
Date: Thu, 10 Sep 2020 14:28:47 -0400

> If that's in there, I would remove my BLOCK.

Thanks, Martin.

> However, I wonder why we wouldn't just hold a WG forming BOF to figure out what
> they're going to do, rather than form the WG and then figure out the initial objectives.
> The latter has the same first meeting while also having less organizational overhead.

Part of the point of this working group is to involve a community that
we know is there and has work to do, but that wouldn't normally go to
an IETF BoF.  It's not that there isn't work to do, nor that there
aren't people prepared to do it, but that the process of getting work
started in the IETF doesn't rope in that community.  We could try
pushing them into that process for a BoF for this working group... or
we can do a slight adaptation for them.  I think the latter is the
better approach, and I think we'll need to look, moving into the
future, at how to continue adapting in order to include different
communities better.

And I do think a "let's check and make sure this is working" thing is
a good idea, so thanks, Martin and Alissa, for pushing on that.

Barry

---

From: Martin Duke <[email-masked]>
Date: Thu, 10 Sep 2020 11:37:57 -0700

That seems like a well-thought-out reason. Carry on.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Sat, 12 Sep 2020 10:07:11 +0200

> On 10. Sep 2020, at 20:28, Barry Leiba <[email-masked]> wrote:
> 
> started in the IETF doesn't rope in that community. 

Not that I want to impact your decision about this working group but I find this argument that people are willing to come to a working group meeting but not to a BoF meeting not very connivence. If people are willing to do work in the IETF, they should should do it within the (actually low amount of) process that we have.

Just my 2c.

Mirja

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 12 Sep 2020 14:49:41 +0000

I believe there is a big difference between a WG -- here is the work we are going to do -- and a BoF -- let's discuss what work we want to do, spend some time in the weeds picking dates and wordsmithing, and hope it gets approved.

To an outsider, it's not a low amount of process.