Subject: [httpapi] Introduction and introducing proposal for standardisation of profile negotiation

From: "Lars G. Svensson" <[email-masked]>
Date: Wed, 3 Feb 2021 17:31:31 +0100

All,

My name is Lars Svensson and while not entirely new to IETF
standardisation (I was active in URNbis) this is my first stab at http
standardisation.

For some time now, Ruben Verborgh, Herbert Van de Sompel and I together
with folks in W3C have been working on a proposal for http content
negotiation using profiles. This is done by adding a new http header
"Accept-Profile" and re-using the "Link"-header (RFC 8288). The proposal
was uploaded as an I-D earlier today [1].

The work has been done in co-operation with the W3C Data Exchange WG [2]
and there is a corresponding document on rec track there [3]. In terms
of implementation work we know of some implementations and would be
happy to share that information, too, if it is of interest.

We ask the WG to consider adopting this draft as part of its work.

[1]
https://www.ietf.org/archive/id/draft-svensson-profiled-representations-00.txt
[2] https://www.w3.org/2017/dxwg/
[3] https://www.w3.org/TR/dx-prof-conneg/

Thanks in advance,

Lars for the authors

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 8 Feb 2021 17:45:59 +0000

Thanks for bringing this forward.  We (the chairs) discussed this, and think that this should be brought forward to the DISPATCH working group (https://datatracker.ietf.org/wg/dispatch/about/)   There is a meeting planned at the next virtual IETF on Monday 2021-03-08 13:00 CET (12:00 UTC). There seems to be plenty of time to get on the agenda; you can find the DISPATCH chairs on the about page.

Our reasons for doing this is that we're not sure about HTTPBIS vs. HTTP-API; clearly cross-collaboration will be required.  Also note that the IETF has a lot of history in this area and we're not quite sure why this would be different and how to ensure success.  Examples include RFC's 2295 2703, 2534, 2912, 2913, the now-closed CONNEG working group (https://datatracker.ietf.org/wg/conneg/about/) and a counter-argument https://wiki.whatwg.org/wiki/Why_not_conneg

Thanks.
Rich, for the chairs.