Subject: Re: [httpapi] Call for Agenda Items for IETF 110

From: Darrel Miller <[email-masked]>
Date: Tue, 2 Mar 2021 17:26:07 +0000

Hey folks,

As IETF 110 is coming up on us quickly,  i.e. next Friday, I'd like to close on the agenda items for the httpapi session.

So, far we have the following items proposed:

---
Update on Deprecation Header
https://datatracker.ietf.org/doc/draft-ietf-httpapi-deprecation-header/
It would be a good to understand where we currently are with the scope of this header regarding how whether it targets an entire resource like the Sunset header, or whether it can be used to signal a deprecation within the resource.

@Erik Wilde<mailto:[email-masked]> @Sanjay Dalal<mailto:[email-masked]> Would one of you be available to drive this conversation?

---
Linkset media type
https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/

It's great to see the announcement from Phil on the implementation of this specification.  I agree that we should make an effort to root out any remaining issues before going to last call.

@Erik Wilde<mailto:[email-masked]> @Herbert Van de Sompel<mailto:[email-masked]> Would one of you be available to drive this conversation?

---
Warning Header
https://datatracker.ietf.org/doc/draft-cedik-http-warning/

There definitely seems to be interest in solving certain problems in this space, but there doesn't yet seem to be clarity on exactly what problem we should be trying to solve.  If we can resolve that we can be in a better position to decide if this draft should be adopted as is or with some modifications.

@André Cedik<mailto:[email-masked]>  Would you be available to drive this conversation?

---
RFC7808bis
https://github.com/ietf-wg-httpapi/rfc7807bis

@Sanjay Dalal<mailto:[email-masked]>  Are you able to speak to this effort?

---
JSON Type serialization registry
Speaking as an individual, I'd like to get sense of interest in the idea of trying to create a r​egistry of standardized JSON serializations for primitive and complex types.  I think it would eliminate a lot of duplication and solve a bunch of interop issues in the API space.

---
If there are other topics that folks would like to present on, please reply to this thread ASAP.

Thanks,
Darrel
________________________________
From: Erik Wilde <[email-masked]>
Sent: Tuesday, January 26, 2021 3:38 AM
To: Darrel Miller <[email-masked]>; [email-masked] <[email-masked]>
Cc: André Cedik <[email-masked]>; Sanjay Dalal <[email-masked]>; Herbert Van de Sompel <[email-masked]>
Subject: Re: [httpapi] Call for Agenda Items for IETF 110

hello darrel.

thanks for getting us started for IETF 110!

On 2021-01-26 04:02, Darrel Miller wrote:
> With this e-mail I would also like to call for agenda items for the
> meeting. If you would like to present please express your intent on the
> mailing list or by contacting the chairs by 26 February.  Due to the
> fairly compressed timeline of our last meeting, for this meeting we have
> scheduled 2 hours.

like at IETF 109, i'd like to request slots for three drafts:

-
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-httpapi-deprecation-header%2F&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C52d316a3744549bc55e708d8c1d5cddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637472471443707125%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=jbm91oCRRq4V%2BcDYwuPoxcIp14scTcoUaotdZ%2FCva0w%3D&amp;reserved=0
has been adopted as a group draft since the last meeting and i am not
aware of open issues around it. maybe we can simply bring it up and
provide the group with a last chance to give their feedback. if no new
issues are raised, this draft probably can go to last call. or is that
even something we can do on the list and then use IETF 110 as a place to
wrap things up?

- https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-httpapi-linkset%2F&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C52d316a3744549bc55e708d8c1d5cddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637472471443707125%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=r5rs0hz%2Bv6Hn1eCvZfcDyKlX2NmC9zEXWh%2Fb0e2vgFo%3D&amp;reserved=0 also has
been adopted as a group draft since the last meeting. we still have a
few minor issues we need to add to the repo. but as you've seen from
phil archer's message, we now have a major implementation out, so it
would be great to try to wrap it up and maybe use IETF 110 as a last
opportunity to give feedback and raise issues.

- https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cedik-http-warning%2F&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C52d316a3744549bc55e708d8c1d5cddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637472471443717086%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=9UqMKCUTB3T%2F54wJnjmFC%2F%2F7%2FCW%2FHJgdLbjFcT%2BVyXU%3D&amp;reserved=0 was
proposed as a group draft last time and has been mentioned on the list
in a variety of messages (in the context of discussing possible
refinements/additions to the RFC 7807 model). maybe it would be good to
bring up the draft again (even though there hasn't been a new version
since IETF 109) to once again gauge interest, and to also see if/how it
can be aligned with ongoing efforts around exposing warning/error
conditions.

i may or may not be presenter for these slots. all three drafts have
co-authors, and i'd be more than happy to step back and let the
co-authors present.

thanks and cheers,

dret.

--
erik wilde | mailto:[email-masked] |
            | https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdret.net%2Fnetdret&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C52d316a3744549bc55e708d8c1d5cddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637472471443717086%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=4NjsQTyfHxFP6ron35vaGrAMcLzxhEu530%2BR5nk2rjI%3D&amp;reserved=0    |
            | https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftwitter.com%2Fdret&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C52d316a3744549bc55e708d8c1d5cddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637472471443717086%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=lzNAsgowSB8dz4JcfefOiR6ZMRK4%2Frx5fQpvQxleDrc%3D&amp;reserved=0    |

---

From: Erik Wilde <[email-masked]>
Date: Wed, 10 Mar 2021 13:19:05 +0100

hello darrel.

my apologies for the delay.

On 2021-03-02 18:26, Darrel Miller wrote:
> As IETF 110 is coming up on us quickly,  i.e. next Friday, I'd like to 
> close on the agenda items for the httpapi session.
> 
> <https://datatracker.ietf.org/doc/draft-ietf-httpapi-deprecation-header/>
> It would be a good to understand where we currently are with the scope 
> of this header regarding how whether it targets an entire resource like 
> the Sunset header, or whether it can be used to signal a deprecation 
> within the resource.
> 
> @Erik Wilde <mailto:[email-masked]> @Sanjay Dalal 
> <mailto:[email-masked]> Would one of you be available to drive 
> this conversation?

i can present unless sanjay would rather do it. i have created a set of 
slides at http://dret.net/lectures/ietf-110/#deprecation and have 
created a PR on the meeting agenda to add that link.

> <https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/>
> 
> It's great to see the announcement from Phil on the implementation of 
> this specification.  I agree that we should make an effort to root out 
> any remaining issues before going to last call.
> 
> @Erik Wilde <mailto:[email-masked]> @Herbert Van de Sompel 
> <mailto:[email-masked]> Would one of you be available to drive this 
> conversation?

it would be great to have herbert doing it. if not, i can add that to my 
list of presentations.

> <https://datatracker.ietf.org/doc/draft-cedik-http-warning/>
> 
> There definitely seems to be interest in solving certain problems in 
> this space, but there doesn't yet seem to be clarity on exactly what 
> problem we should be trying to solve.  If we can resolve that we can be 
> in a better position to decide if this draft should be adopted as is or 
> with some modifications.
> 
> @André Cedik <mailto:[email-masked]>  Would you be available 
> to drive this conversation?

it would be great to have andre doing it. if not, i can add that to my 
list of presentations.

cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Sanjay Dalal <[email-masked]>
Date: Wed, 10 Mar 2021 07:00:44 -0800

Hi Erik, I am ok if you present the Deprecation header.

Darrel/Rich, I am preparing slides for 7807bis but running late. I can try
to send today pst. Is that ok?

thanks.
sanjay

On Wed, Mar 10, 2021 at 4:19 AM Erik Wilde <[email-masked]> wrote:

> > <https://datatracker.ietf.org/doc/draft-ietf-httpapi-deprecation-header/
> >

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 10 Mar 2021 15:05:31 +0000

*   Darrel/Rich, I am preparing slides for 7807bis but running late. I can try to send today pst. Is that ok?

Yes.

The IETF often gets slides the “morning of”

Oops, did I do reply-all? :)

---

From: André Cedik <[email-masked]>
Date: Tue, 16 Mar 2021 08:23:38 +0100

Hi everyone,

sorry for not responding earlier. I am swamped at the moment and had no
chance of attending IETF 110.
Thanks, @Erik Wilde <[email-masked]> for stepping up. I'm hoping that
once I've got a few things in order the next couple of weeks my response
time will drop dramatically :)

Best
André

On Wed, Mar 10, 2021 at 4:06 PM Salz, Rich <[email-masked]> wrote:

>
>    - Darrel/Rich, I am preparing slides for 7807bis but running late. I
>    can try to send today pst. Is that ok?
>
>
>
> Yes.
>
>
>