Subject: [httpapi] Call for adoption https://datatracker.ietf.org/doc/html/draft-idempotency-header-01

From: "Salz, Rich" <[email-masked]>
Date: Fri, 18 Jun 2021 14:13:58 +0000

This is a one-week call for adoption of https://datatracker.ietf.org/doc/html/draft-idempotency-header-01  From the abstract:

   The "HTTP" Idempotency request header field can be used to carry
   idempotency key in order to make non-idempotent "HTTP" methods such
   as "POST" or "PATCH" fault-tolerant.

Sanjay proposed this last month and it received some comments. If you are opposed to the working group adopting this, please post your response, and reasons why, within a week.

Thank you.

---

From: Roberto Polli <[email-masked]>
Date: Fri, 18 Jun 2021 18:11:43 +0200

Hi Rich et al.

> This is a one-week call for adoption of https://datatracker.ietf.org/doc/html/draft-idempotency-header-01  From the abstract:

I think the proposal is interesting and I support the adoption,
as long as the editors are open to some changes.

Here is a brief list of open points:

- the spec comes with a framework for error management similar to
Post-Once-Exactly: I think
  that if this is the goal, it's a "pattern" spec, not a header field
definition.
  Patterns limit the interaction model so I think there's more than
meets the eye here;
  for example, an implementer may not adopt the header because  the
pattern does not suit his needs.
- security considerations needs to be developed;

I'll provide more indepth review next week.
Kind regards,
R

> --
> httpapi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/httpapi

-- 
Roberto Polli
API Expert
M. +39 3406522736
MID
DIPARTIMENTO PER LA
TRASFORMAZIONE
DIGITALE
Presidenza del Consiglio dei Ministri - Ministro per l'innovazione
tecnologica e la digitalizzazione
https://innovazione.gov.it/

Il Dipartimento per la Trasformazione Digitale, salvo eccezioni,
comunica con le altre Amministrazioni via posta elettronica ordinaria
e non posta elettronica certificata, in conformità a quanto previsto
dall’art.47 del Codice dell’Amministrazione Digitale.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 23 Jun 2021 14:26:08 +0000

Posting a reminder since one-week is perhaps not a lot of time.

If you are *opposed* to the working group taking this on, please post an explanation to the list by the end of the week.  Thanks.

From: Rich Salz <[email-masked]>
Date: Friday, June 18, 2021 at 10:13 AM
To: "[email-masked]" <[email-masked]>
Subject: Call for adoption https://datatracker.ietf.org/doc/html/draft-idempotency-header-01

Thank you.

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 25 Jun 2021 20:38:52 +0000

The document is adopted.

The GitHub repository is https://github.com/ietf-wg-httpapi/idempotency  Sanjay, please email me your github ID. If you want help setting it up, such as to use Martin’s I-D tools, ping me.

Most importantly, please submit draft-ietf-httpapi-idempotency-header

From: Rich Salz <[email-masked]>
Date: Wednesday, June 23, 2021 at 10:26 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: Call for adoption https://datatracker.ietf.org/doc/html/draft-idempotency-header-01

Thank you.