Subject: Re: [httpapi] Fwd: New Version Notification for draft-nottingham-link-template-03.txt

From: Darrel Miller <[email-masked]>
Date: Sat, 16 Oct 2021 19:45:46 +0000

Am 01.09.2021 um 07:36 schrieb Mark Nottingham:
> Hi all,
>
> I've had this spec on the back burner for a *long* time, because I
> wanted to make sure it was actually useful to someone before progressing it.
>
> I've heard from a few people that it would be useful for them in the
> real world, so I'd like the WG to consider adoption.
>
> Any thoughts?
>
> Cheers,

I would support adopting this specification.  The notion of var-base could be very helpful in many scenarios.  I have run into cases in OpenAPI where being able attach a globally unique identifier to a URI parameter would be extremely helpful.

I think this could significantly improve the usability of standardized rel values.  It would be nice to be able to communicate things like this:

Link-Template: <https://www.bing.com/search?q={search}> ; rel=”search”; var-base=”https://bing.com/searchparams/”

I also wonder if we could increate applicability by adding support for default values.  E.g.

Link-Template: </messages?skip={skip}&top={top}>; rel="next"; var-base=”https://odata.org/queryparameters”; defaults=(skip=100,top=30)

This would give a combination of a fully resolved URL and a uri template.

Mark. Should we put this on the agenda for IETF 112?

Darrel

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Oct 2021 17:02:19 +1100

Sure. If possible, early in the session, as it will be starting at 11pm on my Friday night.

Cheers,

> On 17 Oct 2021, at 6:45 am, Darrel Miller <[email-masked]> wrote:
> 
>  

--
Mark Nottingham   https://www.mnot.net/