Subject: [httpapi] I-D Action: draft-ietf-httpapi-linkset-07.txt

From: [email-masked]
Date: Tue, 08 Feb 2022 08:26:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Building Blocks for HTTP APIs WG of the IETF.

        Title           : Linkset: Media Types and a Link Relation Type for Link Sets
        Authors         : Erik Wilde
                          Herbert Van de Sompel
	Filename        : draft-ietf-httpapi-linkset-07.txt
	Pages           : 34
	Date            : 2022-02-08

Abstract:
   This specification defines two formats and respective media types for
   representing sets of links as stand-alone documents.  One format is
   JSON-based, the other aligned with the format for representing links
   in the HTTP "Link" header field.  This specification also introduces
   a link relation type to support discovery of sets of links.

Note to Readers

   Please discuss this draft on the "Building Blocks for HTTP APIs"
   mailing list (https://www.ietf.org/mailman/listinfo/httpapi).

   Online access to all versions and files is available on GitHub
   (https://github.com/ietf-wg-httpapi/linkset).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-httpapi-linkset-07.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-httpapi-linkset-07

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Phil Archer <[email-masked]>
Date: Tue, 8 Feb 2022 17:04:11 +0000

Good to see this continuing in its progress., thank you to everyone who made this happen.

Just a little nit pick. The top of the page at https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/ states that, as we have discussed, this is a proposed standard. However, the actual doc within that page, and the HTML version at https://www.ietf.org/archive/id/draft-ietf-httpapi-linkset-07.html, still shows the intended status as informational.

Am I misunderstanding this or is there an actual (small, entirely understandable) error?

Phil

Phil Archer
Web Solutions Director, GS1
https://www.gs1.org

Meet GS1 Digital Link Developers at
https://groups.google.com/forum/#!forum/gs1-digital-link-developers

https://philarcher.org
+44 (0)7887 767755
@philarcher1
Skype: philarcher

-----Original Message-----
From: httpapi <[email-masked]> On Behalf Of [email-masked]
Sent: 08 February 2022 16:26
To: [email-masked]
Cc: [email-masked]
Subject: [httpapi] I-D Action: draft-ietf-httpapi-linkset-07.txt

Abstract:

Note to Readers

--
httpapi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/httpapi

CONFIDENTIALITY / DISCLAIMER: The contents of this e-mail are  confidential and are not to be regarded as a contractual offer or acceptance from GS1 (registered in Belgium). 
If you are not the addressee, or if this has been copied or sent to you in error, you must not use data herein for any purpose, you must delete it, and should inform the sender. 
GS1 disclaims liability for accuracy or completeness, and opinions expressed are those of the author alone. 
GS1 may monitor communications. 
Third party rights acknowledged. 
(c) 2020.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 8 Feb 2022 17:21:48 +0000

On 2/8/22, 12:04 PM, "Phil Archer" <phil.archer=[email-masked]> wrote:
> the actual doc within that page, and the HTML version at https://www.ietf.org/archive/id/draft-ietf-httpapi-linkset-07.html, still shows the intended status as informational.

>    Am I misunderstanding this or is there an actual (small, entirely understandable) error?

The change from catorgy=info to category=std should have been sufficient, but RFC 7991 which defines the XML says its deprecated. But it doesn't say do-not-use so I'll take it up with the rfc-discuss list.  For now, don't worry about it.

Good catch!