Subject: [httpapi] GitHub Project board

From: Darrel Miller <[email-masked]>
Date: Sat, 19 Mar 2022 22:59:20 +0000

In an effort to provide better visibility into the pending issues and current status of work across the httpapi working group I have created a GitHub project board https://github.com/orgs/ietf-wg-httpapi/projects/1/views/1 and added the issues that I believe are currently active for each of the adopted documents.

Based on my reading of the issues I have set the status to either “In Discussion”, “Document Update Required” or “blocked”.  The intent is to distinguish between issues where further input from community members would be valuable, and where editors are simply trying to find time on their calendars to do the necessary writing.

If issue owners feel I have mis-characterized the status of the issue, I would encourage you to set the appropriate status.  Also, if there are a better set of states to capture workflow of issues for these types of documents, I invite feedback.

Darrel

---

From: Erik Wilde <[email-masked]>
Date: Wed, 23 Mar 2022 17:37:08 +0100

hello darrel.

On 2022-03-19 23:59, Darrel Miller wrote:
> In an effort to provide better visibility into the pending issues and 
> current status of work across the httpapi working group I have created a 
> GitHub project board 
> https://github.com/orgs/ietf-wg-httpapi/projects/1/views/1 
> <https://github.com/orgs/ietf-wg-httpapi/projects/1/views/1> and added 
> the issues that I believe are currently active for each of the adopted 
> documents.

that is sweeeeeet! i was afraid we'd end up with duplicated info, but 
this is built into github and always up-to-date. thanks so much, darrel!

> Based on my reading of the issues I have set the status to either “In 
> Discussion”, “Document Update Required” or “blocked”.  The intent is to 
> distinguish between issues where further input from community members 
> would be valuable, and where editors are simply trying to find time on 
> their calendars to do the necessary writing.

and these status values are defined by the project and shown on the 
issues in the repo! i feel stupid for not having used or even known 
about this feature, but it looks very useful!

> If issue owners feel I have mis-characterized the status of the issue, I 
> would encourage you to set the appropriate status.  Also, if there are a 
> better set of states to capture workflow of issues for these types of 
> documents, I invite feedback.

i won't have time to go through these things before tomorrow's meeting, 
but i have blocked next week to do some HTTPAPI homework and this looks 
like a perfect way to get a good overview.

thanks again, darrel! cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://twitter.com/dret    |

---

From: Erik Wilde <[email-masked]>
Date: Wed, 23 Mar 2022 18:02:32 +0100

hello darrel.

On 2022-03-23 17:37, Erik Wilde wrote:
>> If issue owners feel I have mis-characterized the status of the issue, 
>> I would encourage you to set the appropriate status.  Also, if there 
>> are a better set of states to capture workflow of issues for these 
>> types of documents, I invite feedback.

i just wanted to make such a change but couldn't figure out how. i 
assumed that in the board view one can simply drag items, but that 
doesn't seem to work. is it possible that this is a permission issue?

thanks and cheers,

dret.

---

From: Darrel Miller <[email-masked]>
Date: Thu, 24 Mar 2022 03:04:32 +0000

Hey Erik,

Yes, it was a permissions issue.  You should have an invite for access permissions now.

Darrel

From: Erik Wilde<mailto:[email-masked]>
Sent: March 23, 2022 1:02 PM
To: Darrel Miller<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [httpapi] GitHub Project board

hello darrel.

thanks and cheers,

dret.

--
erik wilde | mailto:[email-masked] |
            | https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftwitter.com%2Fdret&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7C798da753cfc040bc6f7008da0ceef30c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637836517794615691%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=RRjMDwUCujNmGSscGQWicjp6PJAn%2Fdeq3DRNxgn4USI%3D&amp;reserved=0    |

---

From: Erik Wilde <[email-masked]>
Date: Thu, 24 Mar 2022 08:45:11 +0100

hello darrel.

> Yes, it was a permissions issue.  You should have an invite for access 

yup, it works now and i have updated the board/status.

thanks again,

dret.