Subject: [httpapi] Francesca Palombini's Yes on draft-ietf-httpapi-linkset-08: (with COMMENT)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Tue, 01 Mar 2022 06:11:36 -0800

Francesca Palombini has entered the following ballot position for
draft-ietf-httpapi-linkset-08: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Lars rightfully noted that two Downref (not in the downref registry) escaped
the IETF Last Call automatically generated text:

  ** Downref: Normative reference to an Informational RFC: RFC 6906
   [RFC6906]  Wilde, E., "The 'profile' Link Relation Type", RFC 6906,
              DOI 10.17487/RFC6906, March 2013,
              <https://www.rfc-editor.org/info/rfc6906>.

  ** Downref: Normative reference to an Informational RFC: RFC 7284
   [RFC7284]  Lanthaler, M., "The Profile URI Registry", RFC 7284,
              DOI 10.17487/RFC7284, June 2014,
              <https://www.rfc-editor.org/info/rfc7284>.

In conformance with https://www.ietf.org/rfc/rfc8067.html, I believe there is
no need for starting another LC for the document including these references,
and I ask the rest of the IESG to pay particular attention to the
appropriateness of these two downward references, as part of their IESG
evaluation.

---

From: Herbert Van de Sompel <[email-masked]>
Date: Thu, 3 Mar 2022 08:51:00 +0100

Dear Francesca,

In order to be able to continue the work on the linkset I-D, I would like
to ask for some guidance:

* In his DISCUSS review, Benjamin Kaduk seems to express a different
opinion than yours regarding how to handle the downrefs vis-a-vis another
Last Call (or not); he asks the IESG to discuss the matter. Am I correct to
assume that there is nothing we as authors can do to address this issue?

* In the same review, Benjamin also correctly points out an error with a
Content-Length in an example, which must be corrected. Other reviewers have
provided some comments that would be good to address as a means to improve
the document quality. Do we start a new version of the I-D in the HTTPAPI
Github repository for that purpose? And will that then automatically mean
another Last Call?

Greetings

Herbert Van de Sompel

On Tue, Mar 1, 2022 at 3:11 PM Francesca Palombini via Datatracker <
[email-masked]> wrote:

> Please refer to
> https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
> --
> httpapi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/httpapi
>

-- 
==================
Herbert Van de Sompel
https://hvdsomp.info
https://orcid.org/0000-0002-0715-6126

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 2 Mar 2022 23:59:35 -0800

Hi Herbert,

I'm not Francesca but should be able to provide useful responses
regardless.

> assume that there is nothing we as authors can do to address this issue?

That's correct that there is no action for the authors at this time.
(In some sense this point is me using technology to mitigate human
weakness, as the meeting where the IESG will discuss the topic is at 0700h
my time and I will not necessarily be awake enough to remember to mention
it, without the extra nudge here.)
For what it's worth, I don't think Francesca's position is inaccurate --
there is no strict requirement to do another Last Call, but it's subject to
the IESG's judgment and I think the topic I raised will be a relevant
factor for the IESG's decision.  I do not attempt to prejudge what the
outcome of the IESG discussion will be.

> Github repository for that purpose? And will that then automatically mean

Yes, please go ahead and start a new version in the github repository.
Such changes will not automatically mean a new Last Call.  (If, in
Francesca's assessment, the changes made are "substantial enough" a last
call might be needed, but there is no process requirement that one will
always be needed.)

Thanks,

Ben

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 3 Mar 2022 13:06:34 +0000

Darrel and I will be meeting Friday.  We know many folks don’t have experience with IESG reviews, so we’ll be figuring out what to tell people about handling them.

From: Herbert Van de Sompel <[email-masked]>
Date: Thursday, March 3, 2022 at 2:51 AM
To: Francesca Palombini <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Rich Salz <[email-masked]>, HTTP APIs Working Group <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Herbert Van de Sompel <[email-masked]>
Subject: Re: [httpapi] Francesca Palombini's Yes on draft-ietf-httpapi-linkset-08: (with COMMENT)

Dear Francesca,

In order to be able to continue the work on the linkset I-D, I would like to ask for some guidance:

* In his DISCUSS review, Benjamin Kaduk seems to express a different opinion than yours regarding how to handle the downrefs vis-a-vis another Last Call (or not); he asks the IESG to discuss the matter. Am I correct to assume that there is nothing we as authors can do to address this issue?

* In the same review, Benjamin also correctly points out an error with a Content-Length in an example, which must be corrected. Other reviewers have provided some comments that would be good to address as a means to improve the document quality. Do we start a new version of the I-D in the HTTPAPI Github repository for that purpose? And will that then automatically mean another Last Call?

Greetings

Herbert Van de Sompel

On Tue, Mar 1, 2022 at 3:11 PM Francesca Palombini via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Francesca Palombini has entered the following ballot position for
draft-ietf-httpapi-linkset-08: Yes

Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/<https://urldefense.com/v3/__https:/www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XigZimEru$>
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3Xijid5fau$>

  ** Downref: Normative reference to an Informational RFC: RFC 6906
   [RFC6906]  Wilde, E., "The 'profile' Link Relation Type", RFC 6906,
              DOI 10.17487/RFC6906, March 2013,
              <https://www.rfc-editor.org/info/rfc6906<https://urldefense.com/v3/__https:/www.rfc-editor.org/info/rfc6906__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XioWSmIL7$>>.

  ** Downref: Normative reference to an Informational RFC: RFC 7284
   [RFC7284]  Lanthaler, M., "The Profile URI Registry", RFC 7284,
              DOI 10.17487/RFC7284, June 2014,
              <https://www.rfc-editor.org/info/rfc7284<https://urldefense.com/v3/__https:/www.rfc-editor.org/info/rfc7284__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XipRIwjJm$>>.

In conformance with https://www.ietf.org/rfc/rfc8067.html<https://urldefense.com/v3/__https:/www.ietf.org/rfc/rfc8067.html__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XiimduSDA$>, I believe there is
no need for starting another LC for the document including these references,
and I ask the rest of the IESG to pay particular attention to the
appropriateness of these two downward references, as part of their IESG
evaluation.

--
httpapi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/httpapi<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/httpapi__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XiotPxpO-$>

--
==================
Herbert Van de Sompel
https://hvdsomp.info<https://urldefense.com/v3/__https:/hvdsomp.info__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3XilIJcvLP$>
https://orcid.org/0000-0002-0715-6126<https://urldefense.com/v3/__https:/orcid.org/0000-0002-0715-6126__;!!GjvTz_vk!Dwc1Fxcodq8nMC1-qk7NYXZDP_QATTMyzF-rnoVdlZj7Dd_CPs3Xiuf6QbOZ$>

---

From: Herbert Van de Sompel <[email-masked]>
Date: Thu, 3 Mar 2022 17:38:43 +0100

Thanks, Benjamin.

We created a new version and started to address comments.

Greetings

Herbert

> On Mar 3, 2022, at 09:00, Benjamin Kaduk <[email-masked]> wrote:
> 
> Hi Herbert,
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 3 Mar 2022 16:40:44 +0000

>    We created a new version and started to address comments.

That is fine.  Please *do not* post a new version to the datatracker, as it will be harder for reviewers to skim a diff, or otherwise easily make sure that their concerns were addressed.

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 3 Mar 2022 17:05:28 +0000

Hi all,

As an update, the IESG discussed the document and in particular the missed normative downward references: they were not picked up by the tool (I’ve opened a ticket about it) and I missed them when sending out the Last Call. My initial opinion was that there was no need to repeat the Last Call, but given that these downref are to ISE Stream documents (and so they are not reflective of IETF consensus), the IESG agreed that delaying 2 weeks to repeat the last call is the better option here.

Additionally, Ben brought up some I18n question. During my AD review I promised to send the document to I18n directorate for review, which I seem to have missed as well – apologies for that.  So these two weeks will allow for I18n to double check the document.

In the meantime, authors (and the working group) you can go ahead and start working on a new version on github as Rich mentioned, based on the IESG evaluation comments: https://datatracker.ietf.org/doc/draft-ietf-httpapi-linkset/ballot/ and continue the conversation with ADs that have kindly submitted reviews. The important thing to remember is that ADs might have questions that will hopefully help clarify the document – it is important that comments are addressed, that does not mean that each comment requires a change, sometimes it is just background that is requested.

If there are any questions, let me know.
Francesca

From: Salz, Rich <[email-masked]>
Date: Thursday, 3 March 2022 at 14:06
To: Herbert Van de Sompel <[email-masked]>, Francesca Palombini <[email-masked]>
Cc: The IESG <[email-masked]>, HTTP APIs Working Group <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [httpapi] Francesca Palombini's Yes on draft-ietf-httpapi-linkset-08: (with COMMENT)
Darrel and I will be meeting Friday.  We know many folks don’t have experience with IESG reviews, so we’ll be figuring out what to tell people about handling them.

Dear Francesca,

Greetings

Herbert Van de Sompel