Subject: Fw: I-D ACTION:draft-nottingham-hdrreg-http-00.txt

From: "Mark Nottingham" <[email-masked]>
Date: Fri, 14 Jun 2002 09:41:32 -0700

----- Original Message -----
From: <[email-masked]>
To: <IETF-Announce:>
Sent: Friday, June 14, 2002 4:30 AM
Subject: I-D ACTION:draft-nottingham-hdrreg-http-00.txt

> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>
>
> Title : Registration of HTTP header fields
> Author(s) : M. Nottingham
> Filename : draft-nottingham-hdrreg-http-00.txt
> Pages : 110
> Date : 13-Jun-02
>
> This document defines the initial IANA registration for some HTTP
> message header fields.
> Discussion of this document
> Please send comments to <[email-masked]>.  To subscribe to this
> list, send a message with the subject'subscribe' to <ietf-http-wg-
> [email-masked]>.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-hdrreg-http-00.txt
>
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the
message.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-nottingham-hdrreg-http-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-nottingham-hdrreg-http-00.txt".
>
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: "Mark Nottingham" <[email-masked]>
Date: Thu, 20 Jun 2002 11:16:26 -0700

This draft will be submitted as the initial values for the HTTP header
registries; please have a look over it for accuracy and completeness
(accuracy is more important at this stage). Much of the data is
machine-generated from the RFC2629 citation library [1]. Please contact me
directly if you have any corrections or questions.

The draft is long, so it may be easier to browse the HTML version [2],
generated from the same page.

1. http://xml.resource.org/public/rfc/bibxml/
2. http://test.mnot.net/http-headers/  [ this URI is NOT guaranteed to be
permanent ]

Thanks,

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 21 Jun 2002 11:41:40 +0200

Hi,

this is only slightly related to the header registry...

RFC2774 (HTTP extension framework) seems to define the concept of extension
headers in custom namespaces (which is a good thing because it makes name
management much easier). HTTP headers which are used without using the HTTP
extension framework (those collected in the registry) all share the same
default namespace (or are in no namespace at all).

I think it would be a good thing if there would be a common definition of
the namespace in which the registered HTTP headers reside, for instance
"urn:ietf:http-headers". This would also simplify mapping of HTTP headers to
WebDAV property names.

Julian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Mark Nottingham
> Sent: Thursday, June 20, 2002 8:16 PM
> To: [email-masked]
> Subject: reminder (was: I-D ACTION:draft-nottingham-hdrreg-http-00.txt)
>
>
>

---

From: "Mark Nottingham" <[email-masked]>
Date: Wed, 26 Jun 2002 17:46:04 -0700

Perhaps
  urn:ietf:http:headers
so that other things like methods, status codes, message types, etc. could
be identified as well (just a suggestion, I'm no URN expert).

Cheers,

----- Original Message -----
From: "Julian Reschke" <[email-masked]>
To: "Mark Nottingham" <[email-masked]>; <[email-masked]>
Sent: Friday, June 21, 2002 2:41 AM
Subject: RE: reminder (was: I-D
ACTION:draft-nottingham-hdrreg-http-00.txt)

> > Subject: reminder (was: I-D
ACTION:draft-nottingham-hdrreg-http-00.txt)