Subject: HTTP headers

From: "rajmahendrah" <[email-masked]>
Date: Sat, 27 Jul 2002 01:17:37 -0400 (EDT)

hello,

How can we get new HTTP headers created?
Does such headers created, turn out to be vendor specific, to be used 
only by the vendors who registers it?
Or once regsitered, any one can use it?
 
And what are extended headers?
 
Any info or pointers will be greatly appreciated

TIA
raj

---

From: "Mark Nottingham" <[email-masked]>
Date: Sun, 28 Jul 2002 20:50:56 -0700

Currently, there is no official way to register HTTP header field-names.
However, you may be interested in [1] a proposal on how such a registry
would be run.

Regards,

1. http://www.ietf.org/internet-drafts/draft-klyne-msghdr-registry-05.txt

---

From: rajmahendra Hedge <[email-masked]>
Date: Mon, 29 Jul 2002 02:14:45 -0400 (EDT)

hi,
Thanks a lot for the reply. 
I am new to HTTP headers and its issues. I have one
more doubt.

I need to define a new HTTP header for communciation
between my Server application, and other client
application which connect to my Server application. 
If there is no official way to register HTTP header
names, is it enough that I decide on the header name,
and its value, etc? And let know my client
applications about this new header through
documentation?

I need not register it anywhere now, isn't it?
And if the proposed registry is up, probably I can get
it registered there.
Is this the way to do it?

Thanks once again for your time.

Best Regards,
Raj,

--- Mark Nottingham <[email-masked]> wrote: >
Currently, there is no official way to register HTTP
> header field-names.
> 1.
http://www.ietf.org/internet-drafts/draft-klyne-msghdr-registry-05.txt

________________________________________________________________________
Want to sell your car? advertise on Yahoo Autos Classifieds. It's Free!!
       visit http://in.autos.yahoo.com

---

From: Alex Rousskov <[email-masked]>
Date: Mon, 29 Jul 2002 18:38:09 -0600 (MDT)

On Mon, 29 Jul 2002, [iso-8859-1] rajmahendra Hedge wrote:

> I need to define a new HTTP header for communciation between my
> Server application, and other client application which connect to
> my Server application.  If there is no official way to register
> HTTP header names, is it enough that I decide on the header name,
> and its value, etc? And let know my client applications about this
> new header through documentation?

Yes. You may want to name your header field starting with "X-" to
avoid possible but unlikely collisions with [future] "official" header
field names and to follow a tradition. For example:
	X-Rajmahendra: foo=bar

You probably want to keep the value syntax simple so that
intermediaries do not have trouble parsing or forwarding the values.
If possible, avoid things like quoted strings with special delimiters
inside, etc.
 
If you header has a hop-by-hop semantics (see RFC 2616), you must list
it in the Connection: header field.

> I need not register it anywhere now, isn't it?

You do not need to register it.

HTH,

Alex.