Subject: Nature of Application Protocols!

From: "Naresh Agarwal" <[email-masked]>
Date: Thu, 29 Aug 2002 12:39:14 +0530

Hi

I have some general questions regarding protocols.

Every application protocol is -

1)Synchronous or Asynchrnous
2)Connection Less or Connection Oriented
3)Push or Pull

My understanding is that most of the protocols - HTTP, FTP, SMTP, POP, IMAP etc. are "Syncronous", "Connection Less" and "Push" in nature.

I could not find any protocol, which is widely used and is Asynchronus, Connection Oriented and Pull in nature!

Am i right or i'm missing something?

Also does Synchrony and Pull, Asynchrony and Push are synonyms..i.e every Synchronous protocol is Push and every Asynchronous protocol is Push..?

Can somebody provide me with the explanation of above (if possible, with examples)?

thanks,
regards,
Naresh Agarwal

---

From: Martin Duerst <[email-masked]>
Date: Thu, 29 Aug 2002 16:56:39 +0900

HTTP is synchonous, but very much pull, not push.

Regards,    Martin.

At 12:39 02/08/29 +0530, Naresh Agarwal wrote:

>My understanding is that most of the protocols - HTTP, FTP, SMTP, POP, 
>IMAP etc. are "Syncronous", "Connection Less" and "Push" in nature.
>
>Also does Synchrony and Pull, Asynchrony and Push are synonyms..i.e every 
>Synchronous protocol is Push and every Asynchronous protocol is Push..?
>

---

From: "Naresh Agarwal" <[email-masked]>
Date: Thu, 29 Aug 2002 14:08:29 +0530

I'm sorry..it was a typo error...

i meant to say that -

HTTP, FTP, SMTP, POP, IMAP etc. are "Syncronous", "Connection Less" and "Pull" in nature.

regards,
Naresh Agarwal

> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: Thursday, August 29, 2002 1:27 PM
> To: Naresh Agarwal; [email-masked]
> Subject: Re: Nature of Application Protocols!
> 
> 
> 
> >I could not find any protocol, which is widely used and is 
> Asynchronus, 
> >Connection Oriented and Pull in nature!
> >
> >Can somebody provide me with the explanation of above (if 
> possible, with 
> >examples)?
> >
> >thanks,
> >regards,
> >Naresh Agarwal
> 
>

---

From: "Naresh Agarwal" <[email-masked]>
Date: Thu, 29 Aug 2002 14:31:25 +0530

Hi Martin,

Can you elaborate, why SMTP is Push?

First, let me tell you, what i think of Push and Pull.
Please correct me, if i'm wrong.

Pull: You make a request to fetch some data (Request-Response)
Push: You receive some data, without making a request. (No Request, Only Response)

In case of SMTP, data, i.e, mails are pushed to SMTP servers.
But finally, one've to use POP/IMAP to fetch the mails. 

Don't this mean that SMTP is pull rather than push?

thanks,
regards,
Naresh Agarwal

> Sent: Thursday, August 29, 2002 2:18 PM
> Subject: RE: Nature of Application Protocols!
> 
> 
> 
> Well, SMTP is definitely push. FTP can be used both ways.
> Roughly upload = push, download = pull.     Martin.
> 
> At 14:08 02/08/29 +0530, Naresh Agarwal wrote:
> 
> >HTTP, FTP, SMTP, POP, IMAP etc. are "Syncronous", 
> "Connection Less" and 
> >"Pull" in nature.
> >
> >regards,
> >Naresh Agarwal
> >

---

From: "Woodhouse, Gregory J." <[email-masked]>
Date: Thu, 29 Aug 2002 09:28:15 -0700

But, of course SMTP isn't stateless (if that's what you mean by
"connectionless"). Offhand, I can't think of any IETF application protocols
that are both stateless ansd based on the push model  If you relax the layer
7 requirement and look at IP core protocols, that's another matter. One
protocol that is an application layer protocol that supports stateless push
is Health Level 7 (or just HL7, see http://www.hl7.org). I've developed a
number of interfaces baseed on a request/reply semantic similar to HTTP, but
there are messages such as Master File Notification (MFN) that are used to
send unsolicited updates to tables (e.g., to record the fact that a patient
has been admitted). There is an acknowledgement protocol (I send you an MFN,
you then send me Commit Ack (CA) to tell me you have the message and then a
Master File Acknowledgement (MFK) to indicate that it has been processed,
but unlike SMTP, this doesn't occur in the context of a single "session").

===
Gregory Woodhouse  <[email-masked]>
System Design & Development
+1 510 768 6862

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]]
Sent: Thursday, August 29, 2002 7:36 AM
To: [email-masked]
Subject: Re: Nature of Application Protocols!

> Well, SMTP is definitely push. FTP can be used both ways.

As can HTTP. Poor, neglected PUT...

---

From: Martin Duerst <[email-masked]>
Date: Fri, 30 Aug 2002 11:36:27 +0900

>Don't this mean that SMTP is pull rather than push?

Please don't mix up SMTP and 'Internet mail'. SMTP is push, and stateful.
'Internet mail' is a 'protocol' (in the sense that it is a
collection of conventions for communication) consisting of
several actual protocols at layer 7. 'Internet mail' as a whole
may be called stateless (there are states at a still higher level,
in that mails get identified as replies to other mails,...).
'Internet mail' as a whole requires both pull and push
(if only one is done, the email won't reach the recipient),
and therefore cannot be called either 'pull' or 'push'.

Regards,    Martin.