Subject: RE: Nature of Application Protocols!

From: Martin Duerst <[email-masked]>
Date: Thu, 29 Aug 2002 17:47:58 +0900

Well, SMTP is definitely push. FTP can be used both ways.
Roughly upload = push, download = pull.     Martin.

At 14:08 02/08/29 +0530, Naresh Agarwal wrote:

>I'm sorry..it was a typo error...
>
>i meant to say that -
>
>HTTP, FTP, SMTP, POP, IMAP etc. are "Syncronous", "Connection Less" and 
>"Pull" in nature.
>
>regards,
>Naresh Agarwal
>
> > -----Original Message-----
> > From: Martin Duerst [mailto:[email-masked]]
> > Sent: Thursday, August 29, 2002 1:27 PM
> > To: Naresh Agarwal; [email-masked]
> > Subject: Re: Nature of Application Protocols!
> >
> >
> >
> > HTTP is synchonous, but very much pull, not push.
> >
> > Regards,    Martin.
> >
> >
> > At 12:39 02/08/29 +0530, Naresh Agarwal wrote:
> >
> > >Hi
> > >
> > >I have some general questions regarding protocols.
> > >
> > >Every application protocol is -
> > >
> > >1)Synchronous or Asynchrnous
> > >2)Connection Less or Connection Oriented
> > >3)Push or Pull
> > >
> > >My understanding is that most of the protocols - HTTP, FTP,
> > SMTP, POP,
> > >IMAP etc. are "Syncronous", "Connection Less" and "Push" in nature.
> > >
> > >I could not find any protocol, which is widely used and is
> > Asynchronus,
> > >Connection Oriented and Pull in nature!
> > >
> > >Am i right or i'm missing something?
> > >
> > >Also does Synchrony and Pull, Asynchrony and Push are
> > synonyms..i.e every
> > >Synchronous protocol is Push and every Asynchronous protocol
> > is Push..?
> > >
> > >Can somebody provide me with the explanation of above (if
> > possible, with
> > >examples)?
> > >
> > >thanks,
> > >regards,
> > >Naresh Agarwal
> >
> >

---

From: "Mark Nottingham" <[email-masked]>
Date: Thu, 29 Aug 2002 07:35:54 -0700

> Well, SMTP is definitely push. FTP can be used both ways.

As can HTTP. Poor, neglected PUT...

---

From: Martin Duerst <[email-masked]>
Date: Fri, 30 Aug 2002 11:31:20 +0900

>As can HTTP. Poor, neglected PUT...

Of course, I should have known. I use it everyday,
the most natural way to edit Web pages.

Regards,    Martin.

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 30 Aug 2002 08:59:37 -0700

Personally, I think "pull" or "push" are better applied to
applications than to protocols. Web browsing is mainly 'pull', and
sending email is mainly 'push'.  Both HTTP and SMTP
have 'pull' and 'push' operations.

The verbs apply to the relationship of the main data
flow to the initiator. When sending email, the initiator
sends the data (usually), and when browsing the web,
the data is (mainly) sent to the initiator.

These are informal terms which are useful to describe
the gross characteristics of an application but don't
have useful formal definitions.

W3C Workshop on Push Technology (1997)
  http://www.w3.org/Architecture/9709_Workshop/

Larry
-- 
http://larry.masinter.net