Subject: RE: cookies history

From: "Gyula Lanyi" <[email-masked]>
Date: Wed, 23 Oct 2002 23:13:00 -0400 (EDT)

Hi, my name is Tunde (I am a student) and I'm doing a research about cookies. So far, I've got lots of information about them, but I couldn't figure out who invented it and when, and what was its original purpose.
If you, please, can help me, how and where to find out more about the "cookie-history", I would be very thankful.

Thank you in advance for your precious help. Best regards,

Tunde

---

From: Dave Kristol <[email-masked]>
Date: Thu, 24 Oct 2002 09:19:10 -0400

Gyula Lanyi wrote:
> Hi, my name is Tunde (I am a student) and I'm doing a research about 
> cookies. So far, I've got lots of information about them, but I couldn't 
> figure out who invented it and when, and what was its original purpose.
> If you, please, can help me, how and where to find out more about the 
> "cookie-history", I would be very thankful.

The short answer to your question is that Lou Montulli invented cookies 
at Netscape sometime in 1994 to facilitate electronic commerce applications.

I suggest two resources:

1) The Cookie Central web site (cookiecentral.com) contains lots of 
information about cookies, though I don't see any specific section on 
history.

2) My paper, "HTTP Cookies:  Standards, Privacy, and Politics," 
available at <http://arXiv.org/abs/cs.SE/0105018> (and published in 
roughly the same form in ACM Transactions on Internet Technology, Vol.1, 
#2, Nov., 2001) covers the evolution of the HTTP standard, which isn't 
exactly what you want.  (However, look at the first section of the 
Appendix.)

Dave Kristol