Subject: 502 Proxy Error problem

From: "Voronkov Konstantin" <[email-masked]>
Date: Mon, 24 Mar 2003 10:33:10 -0500 (EST)

Hello All!
 
I have a problem when connecting through MS ISA proxy server.
I'm posting data:
 
POST http://212.74.173.246:80 HTTP/1.1
Host: 212.74.173.246:80
Content-Type: application/octet-stream
Connection: close
Proxy-Connection: close
Pragma: no-cache
Cache-Control: no-cache
Cache-Control: no-transform
Content-Length: 106
data...
 
But sometimes (approximately 1/2 of requests) server returns
502 Proxy Error.
 
First request passes successfully always. But next request may not pass
 and server returns error
 
What is wrong with my request?
 
Regards,
Voronkov Konstantin
ICQ 40202717

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Wed, 26 Mar 2003 12:24:42 +0100

Assume you don't do pipelining the requests?

Next take a look at the logs (especially Proxy log and packet filter log,
maybe the firewall log), these might indicate the rule that fails (you get a
very very rough idea of what might go wrong or left completely in the dark).
Maybe there is a BLOCKED request/packet.
Please try to log as much information as possible (except payloads).

What else to do, I don't know....

- Joris

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Voronkov Konstantin
>Sent: Monday, 24 March 2003 16:33
>To: [email-masked]
>Subject: 502 Proxy Error problem
>
>
>
>
>
>
>Hello All!
>

---

From: "Voronkov Konstantin" <[email-masked]>
Date: Thu, 27 Mar 2003 05:37:46 -0500 (EST)

Hello again!

I did a little bit more debugging and see that
 if timeout expired ISA server in response returns following:

Via:1.1 TEST-W2K-SERVER
Connection: close
Proxy-Connection: close
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 3591

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
...

I didn't checked this situation because I expected
HTTP/1.1 xxx OK
in response.

Thanks for your help,
Konstantin

---

From: "Voronkov Konstantin" <[email-masked]>
Date: Thu, 27 Mar 2003 09:43:21 -0500 (EST)

sorry for last post.
ISA works fine. I did not handle ISA error 504 (proxy timeout)

Sorry for taking your time,
Konstantin

----- Original Message -----
From: "Voronkov Konstantin" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 27, 2003 1:37 PM
Subject: Re: 502 Proxy Error problem

> > maybe the firewall log), these might indicate the rule that fails (you
get
> a