Subject: RE: POST

From: Vijayabhaskar_Mamidi <[email-masked]>
Date: Tue, 4 Mar 2003 18:53:20 +0530

RFC mentions that Origin servers *MAY* send 100 continue if expect header is
not sent from client. When is the data sent if there is no expect header in
use

-----Original Message-----
From: Scott Lawrence [mailto:[email-masked]]
Sent: Tuesday, March 04, 2003 6:51 PM
To: Vijayabhaskar_Mamidi
Cc: [email-masked]'
Subject: Re: POST

Vijayabhaskar_Mamidi <[email-masked]> writes:

> 	when is the data sent in a post request .Does the client send the
> data at the initiating request ort does it wait for some sort of
> conformation from the server( No Expect headers are being used).

HTTP/1.1 allows for the use of a 100 Continue response to signal
readiness from the server:

  http://www.apps.ietf.org/rfc/rfc2616.html#sec-8.2.3

-- 
Scott Lawrence        
  Actively seeking work 
  http://world.std.com/~lawrence/

---

From: Scott Lawrence <[email-masked]>
Date: 04 Mar 2003 09:29:06 -0500

> not sent from client. When is the data sent if there is no expect header in

Whenever the client wants to send it.  Because 100 Continue was not in
earlier versions of the protocol, we could not require that the client
wait for it; besides, in some applications it wouldn't be worth the
extra round trip time and server load.

-- 
Scott Lawrence        
  Actively seeking work 
  http://world.std.com/~lawrence/
  [ <[email-masked]> is deprecated ]