Subject: Content Encoding and transfer encoding

From: Diwakar Shetty <[email-masked]>
Date: Mon, 28 Jul 2003 19:00:36 +0530

Suppose I want to compress as well as chunk the response using following response headers:

Content-Encoding: gzip
Transfer-Encoding: chunked

What should be done first by server ? Chunking of response or compression of response ?

-- Diwakar

---

From: Scott Lawrence <[email-masked]>
Date: Mon, 28 Jul 2003 11:05:54 -0400

> What should be done first by server ? Chunking of response or compression

Content-Encoding applies to the entity; Transfer-Encoding appies to
the message body.  Since the entity is inside the message body, the
sender applies Content-Encoding first, then Transfer-Encoding; the
recipient does the reverse.

-- 
Scott Lawrence        
  http://skrb.org/scott/
  [ <[email-masked]> is deprecated ]