Subject: Re: PATCH thoughts...

From: Mark Nottingham <[email-masked]>
Date: Sun, 2 May 2004 20:10:21 -0700

Does the below imply that this proposal would effectively become "how 
to use delta encoding in PUT requests," with PATCH being a means to 
assure that it won't be misinterpreted as a plain PUT by non-PATCH 
aware implementations?

If so, there's a quite prescient note in RFC3229:

>         Nothing in this specification specifically precludes the use of
>          a delta encoding for the body of a PUT request.  However, no
>          mechanism currently exists for the client to discover if the
>          server can interpret such messages, and so we do not attempt 
> to
>          specify how they might be used.

On Apr 30, 2004, at 3:23 PM, Jeffrey Mogul wrote:

>     Modelling on the RFC3229 approach, PATCH could look like
>     this instead:
>
> 	   PATCH /file.txt HTTP/1.1
> 	   Host: foo
> 	   If-Match: "def"
> 	   Content-encoding: gzip
> 	   IM: vcdiff
>
>            [body]
>
> Seems reasonable to me :-)
>
> -Jeff
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Lisa Dusseault <[email-masked]>
Date: Mon, 3 May 2004 09:41:02 -0700

That's pretty much how I saw it, yeah.

lisa