Subject: Confused about

From: "Serkant Karaca" <[email-masked]>
Date: Sun, 16 Oct 2005 22:46:57 +0300

OK, I too, am confused about why proxies MUST NOT establish
persistent connections with 1.0 clients.  If the client and
origin server connections are handled separately, and if the
proxy understands the 1.0 Keep-alive, what's the danger?

> 8.1.3	Proxy Servers
>
> It is especially important that proxies correctly implement 
> the properties of the Connection header field as specified in 14.2.1.
> The proxy server MUST signal persistent connections 
> separately with its clients and the origin servers (or other 
> proxy servers) that it connects to. Each persistent 
> connection applies to only one transport link.
>
> A proxy server MUST NOT establish a persistent connection 
> with an HTTP/1.0 client (but see RFC 2068 for information 
> about the Keep-Alive header implemented by many HTTP/1.0 clients).

Serkant KARACA
Senior Software Engineer
Ankara/Turkey
http://emrealtug.blogspot.com

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 18 Oct 2005 08:22:23 -0600

> proxy understands the 1.0 Keep-alive, what's the danger?

The RFC 2616 text you are looking at is probably talking about
establishing *HTTP/1.1-style* persistent connections with HTTP/1.0
clients. In other words, proxies MUST NOT use HTTP/1.1 connection
mechanisms when talking to HTTP/1.0 clients. As the reference to RFC
2068 may imply, it is fine for a proxy to use appropriate HTTP/1.0
mechanisms with an HTTP/1.0 client.

Alex.

---

From: "Max Clark" <[email-masked]>
Date: Tue, 18 Oct 2005 08:52:38 -0700

please delete