Subject: FYI: draft-nottingham-http-link-header-00

From: Mark Nottingham <[email-masked]>
Date: Thu, 22 Jun 2006 11:23:54 -0700

> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
>
> 	Title		: HTTP Header Linking
> 	Author(s)	: M. Nottingham
> 	Filename	: draft-nottingham-http-link-header-00.txt
> 	Pages		: 9
> 	Date		: 2006-6-19
> 	
>    This specification clarifies the status of the Link HTTP header and
>    introduces the complimentary Profile and Link-Template HTTP  
> headers.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-http-link- 
> header-00.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> i-d-announce-request at ietf.org with the word unsubscribe in the  
> body of the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the  
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-nottingham-http-link-header-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	mailserv at ietf.org.
> In the body type:
> 	"FILE /internet-drafts/draft-nottingham-http-link-header-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> <ftp://ftp.ietf.org/internet-drafts/draft-nottingham-http-link- 
> header-00.txt>
>
> _______________________________________________
> I-D-Announce mailing list
> I-D-Announce at ietf.org
> https://www1.ietf.org/mailman/listinfo/i-d-announce

--
Mark Nottingham     http://www.mnot.net/

---

From: "Anne van Kesteren" <[email-masked]>
Date: Thu, 22 Jun 2006 20:32:55 +0200

On Thu, 22 Jun 2006 20:23:54 +0200, Mark Nottingham <[email-masked]> wrote:
>> http://www.ietf.org/internet-drafts/draft-nottingham-http-link-header-00.txt

Mark++

Any chance you include Default-Style as well  
http://www.w3.org/TR/1999/REC-html401-19991224/present/styles.html#h-14.3.2  
in some future version?

Regarding the draft, it's important that the draft says that any Link  
headers should be added before <link> relations included in the document  
so that CSS cascade and such works out ok.

-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 22 Jun 2006 11:37:02 -0700

On 2006/06/22, at 11:32 AM, Anne van Kesteren wrote:
>
> Any chance you include Default-Style as well http://www.w3.org/TR/ 
> 1999/REC-html401-19991224/present/styles.html#h-14.3.2 in some  
> future version?

Default-Style is already in the Message Header registry:
  http://www.iana.org/assignments/message-headers/perm-headers.html

Are you saying that its status is ambiguous, or that it's not well- 
defined?

> Regarding the draft, it's important that the draft says that any  
> Link headers should be added before <link> relations included in  
> the document so that CSS cascade and such works out ok.

Could you expand upon that? I'm not sure I'm following you.

Cheers,

---

From: "Anne van Kesteren" <[email-masked]>
Date: Thu, 22 Jun 2006 20:44:55 +0200

On Thu, 22 Jun 2006 20:37:02 +0200, Mark Nottingham <[email-masked]> wrote:
>> 1999/REC-html401-19991224/present/styles.html#h-14.3.2 in some future  
>> version?
>

I actually didn't know it was in there. :-o It points back to HTML4 though  
which doesn't really give a solid definition. It's more an example of  
usage.

>> headers should be added before <link> relations included in the  
>> document so that CSS cascade and such works out ok.
>

Say the document has the following snippet:

  <head>
   <style type="text/css">
    p { background:lime }
   </style>
  </head>

... it should be clear that Link enters the (CSS) cascade before that. So  
that if you attach a style sheet using Link containg `p { background:red  
}`, <p> elements will have a green background.

See also the last paragraph of  
http://www.w3.org/TR/1999/REC-html401-19991224/present/styles.html#h-14.6  
for another way of saying it. I think this should be in the specification  
that defines Link rather than in every specification that defines a way to  
attach style sheets in documents like <svg:style>, <html:style>,  
<html:link> and <?xml-stylesheet?>...

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 22 Jun 2006 12:02:11 -0700

On 2006/06/22, at 11:44 AM, Anne van Kesteren wrote:
> ... it should be clear that Link enters the (CSS) cascade before  
> that. So that if you attach a style sheet using Link containg `p  
> { background:red }`, <p> elements will have a green background.
>
> See also the last paragraph of http://www.w3.org/TR/1999/REC- 
> html401-19991224/present/styles.html#h-14.6 for another way of  
> saying it. I think this should be in the specification that defines  
> Link rather than in every specification that defines a way to  

Something like:

"If a format defines a compatible mechanism for embedding links where  
ordering may be significant (e.g., the LINK element in HTML), Link  
HTTP headers SHOULD be considered to occur before them."

?

---

From: "Anne van Kesteren" <[email-masked]>
Date: Thu, 22 Jun 2006 21:06:22 +0200

On Thu, 22 Jun 2006 21:02:11 +0200, Mark Nottingham <[email-masked]> wrote:
> ordering may be significant (e.g., the LINK element in HTML), Link HTTP  
> headers SHOULD be considered to occur before them."

Yeah, although I'd use MUST.