Subject: FW: Review request

From: Larry Masinter <[email-masked]>
Date: Fri, 18 Aug 2006 09:37:45 -0700

I had trouble writing what I thought about this
paper, so I thought I would 'forward this link
to other people that may be interested in this
topic'.

Larry

-----Original Message-----
From: Paul Adamczyk [mailto:[email-masked]] 
Sent: Wednesday, August 16, 2006 8:22 PM
To: [email-masked]
Subject: Review request

Dr. Masinter,

I am contacting you, an author of the HTTP/1.1 standard, to request a review
of my paper, which discusses the relationship between HTTP and Web services.
I am very interested in your opinion about this topic.

Please visit: pinky.cs.uiuc.edu/~padamczy/docs/http_ws_draft.pdf

Feel free to forward this link to other people that may be interested in
this topic.

Thank you,

Paul Adamczyk
PhD student
University of Illinois

---

From: "Joe Gregorio" <[email-masked]>
Date: Fri, 18 Aug 2006 13:49:46 -0400

The entire thesis is based on a false premise: that you
standardize only on what is currently in use on the
most popular sites. If that were the case and this thesis
was written about HTML instead of HTTP then I'm sure
all the suggestions would be to drop CSS and go back
to tables, font tags and invisible spacer gifs.

   -joe

-- 
Joe Gregorio        http://bitworking.org

---

From: "Mark Baker" <[email-masked]>
Date: Fri, 18 Aug 2006 14:14:18 -0400

Hmm, the paper claims;

"We show how to eliminate parts of HTTP/1.1, making it smaller and
easier to implement."

Yet their suggestions are to;

(1) Remove OPTIONS, PUT, DELETE, and TRACE messages
from the standard. The Allow header should also
be removed.
(2) Retain the HEAD message, but clarify its purpose.
(3) Make the Via header mandatory in all messages. This
suggestion is consistent with the HTTP/1.1 errata [16].

Which would perhaps shrink the spec by a couple of pages, but AFAICT,
not make it any easier to implement.  Plus, as Joe observes,
standardizing on what's used, rather than on what works, seems a bit
silly.

I think the paper would have been much better if the work that was
done was recast simply as an examination of current practice with
HTTP.

Also, I felt the SOAP based Web services stuff was out of place.

Mark.