Subject: NEW ISSUE: redirection vs location

From: Julian Reschke <[email-masked]>
Date: Thu, 19 Apr 2007 16:17:06 +0200

Hi,

we recently discussed the definition of the Location header on a JSR 
mailing list.

The definition currently says: 
<http://greenbytes.de/tech/webdav/rfc2616.html#rfc.section.14.30>:

"The Location response-header field is used to redirect the recipient to 
a location other than the Request-URI for completion of the request or 
identification of a new resource. (...)"

The issue is that this can be read as if the "...or identification..." 
can be read as applying to the "redirect" part.

One simple fix seems to be to swap the two parts of the sentence, as in...:

"The Location response-header field is used for the identification of a 
new resource or to redirect the recipient to a location other than the 
Request-URI for completion of the request. (...)"

Feedback appreciated,

Julian

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Thu, 19 Apr 2007 19:25:31 +0200

> Request-URI for completion of the request. (...)"

I agree that switching the two sentences makes it clearer. +1.

-- 
Asbjørn Ulsberg     -=|=-    http://virtuelvis.com/quark/
«He's a loathsome offensive brute, yet I can't look away»

---

From: Eric Lawrence <[email-masked]>
Date: Thu, 19 Apr 2007 10:39:19 -0700

The proposed change nicely corrects the order of the sentence to match the elaborations provided in the following two lines.

 The Location response-header field is used for the identification of a
 new resource or to redirect the recipient to a location other than the
 Request-URI for completion of the request.

 For 201 (Created) responses, the Location is that of the new
 resource which was created by the request. For 3xx responses,
 the location SHOULD indicate the server's preferred URI for
 automatic redirection to the resource. The field value consists
 of a single absolute URI.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Apr 2007 17:29:02 +1000

Now issue 61;
   http://www.w3.org/Protocols/HTTP/1.1/rfc2616bis/issues/#i61

On 20/04/2007, at 12:17 AM, Julian Reschke wrote:

>
> Hi,
>
> we recently discussed the definition of the Location header on a  
> JSR mailing list.
>
> The definition currently says: <http://greenbytes.de/tech/webdav/ 
> rfc2616.html#rfc.section.14.30>:
>
> "The Location response-header field is used to redirect the  
> recipient to a location other than the Request-URI for completion  
> of the request or identification of a new resource. (...)"
>
> The issue is that this can be read as if the "...or  
> identification..." can be read as applying to the "redirect" part.
>
> "The Location response-header field is used for the identification  
> of a new resource or to redirect the recipient to a location other  
> than the Request-URI for completion of the request. (...)"
>
>
> Feedback appreciated,
>
> Julian
>

--
Mark Nottingham     http://www.mnot.net/