Subject: Revised charter proposal

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Jul 2007 23:48:35 -0700

HyperText Transfer Protocol Revision (http-bis) Charter

Last Modified: 2007-07-25

Chair(s):
[TBD]

Applications Area Director(s):
Chris Newman <[email-masked]>
Lisa Dusseault <[email-masked]>

Applications Area Advisor:
[TBD]

Mailing Lists:
General Discussion: [email-masked]
To Subscribe: [email-masked]
In Subject: subscribe
Archive: http://lists.w3.org/Archives/Public/ietf-http-wg/

Description of Working Group:
HTTP is one of the most successful and widely-used protocols on the  
Internet today. However, its specification has several editorial  
issues. Additionally, after years of implementation and extension,  
several ambiguities have arisen, impairing interoperability and the  
ability to easily implement and use HTTP to its full potential.

The working group will refine RFC2616 to:
   * Incorporate errata and updates
   * Improve editorial quality
   * Clarify conformance requirements
   * Remove known ambiguities where they affect interoperability
   * Clarify methods of extensibility
   * Remove or deprecate those features that are not widely  
implemented, unduly affect interoperability and are not well-supported
   * Where necessary, add implementation advice
   * Document the security properties of HTTP and its associated  
mechanisms (e.g., Basic and Digest authentication, cookies, TLS) for  
common applications

In doing so, it should consider:
   * Implementer experience
   * Demonstrated use of HTTP
   * Impact on existing implementations and deployments

The Working Group must not introduce a new version of HTTP, and  
should not introduce new features or capabilities to HTTP.

The Working Group's specification deliverables are:
    * A document that is suitable to supersede RFC 2616
    * A document cataloguing the security properties of HTTP

Additionally, the Working Group should review (and may document) test  
suites for HTTP conformance, as they are made available.

Goals and Milestones:
Sep 2007 - First HTTP Revision Internet Draft
Nov 2007 - First HTTP Security Properties Internet Draft
Dec 2007 - IETF 70 Meeting, Vancouver, BC, Canada
Mar 2008 - IETF 71 Meeting, Philadelphia, PA, USA
Apr 2008 - Request Last Call for HTTP Revision
May 2008 - Request Last Call for HTTP Security Properties
Jul 2008 - IETF 72 Meeting, TBD
Aug 2008 - Submit HTTP Revision to IESG for consideration as a Draft  
Standard
Aug 2008 - Submit HTTP Security Properties to IESG for consideration  
as Informational

--
Mark Nottingham     http://www.mnot.net/

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 27 Jul 2007 07:43:50 -0500

I like this charter.

       Harald

---

From: Julian Reschke <[email-masked]>
Date: Fri, 27 Jul 2007 14:52:34 +0200

> I like this charter.

Me too. In particular the aggressive time line!

Best regards, Julian

---

From: Marcelo Schmidt <[email-masked]>
Date: Fri, 27 Jul 2007 09:24:40 -0700

Mark,

This charter looks great.  I like specially this _reality_ check:

I'll try to help on the above on my _free_ time.

-- 
-m

====================================================================
Key fingerprint = 8E48 6CD0 6D2B 538E 264B  D1D0 21E2 E7EE A40F 2A0B
gpg --keyserver wwwkeys.pgp.net --recv-keys 0xA40F2A0B
====================================================================

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 27 Jul 2007 11:39:53 -0700

Some minor suggestions to the charter, for your consideration:

OLD:
   Additionally, after years of implementation and extension,  
   several ambiguities have arisen, impairing interoperability and the  
   ability to easily implement and use HTTP to its full potential.

s/arisen/become evident/
  (the ambiguities were there)
s/use HTTP to its full potential./use HTTP./
  (potential would include controlling coffee pots)
-----------------------------------------------------------------
Add:
   * Update references

(I think this is necessary)
------------------------------------------------------------------
   * Include (non-normative) references to
     extensions and applicability statements

(More controversial, but I think a reference to BCP 56/RFC 3205 would
be in order, as well as a reference to WebDAV and other protocols 
that use HTTP as a substrate)
------------------------------------------------------------------
OLD:
 * Improve editorial quality

NEW:
 * Fix editorial problems which have led to
   misunderstandings of the specification

(you don't want to be mandated to fix all editorial problems)
-------------------------------------------------------------
OLD: 
 * Remove or deprecate those features that are not widely  
   implemented, unduly affect interoperability and are not well-supported

NEW:
  * Remove or deprecate those features that are
    not widely implemented, not well-supported and also
    unduly affect interoperability.

(I think that's what you meant, but I wasn't sure of the
scope of the 'and'. I'm not actually clear on what is intended by
'not well-supported', though.)
-----------------------------------------------------------
OLD:
  Additionally, the Working Group should review (and may document) test  
  suites for HTTP conformance, as they are made available.

s/should review (and may document)/may review (and document)/

(You don't want to be mandated to consider test suites if
you're otherwise done.)
------------------------------------------------------------------
OLD:
   * Clarify methods of extensibility

NEW:
   * Clarify existing methods of extensibility