Subject: Custom Ranges

From: "Kornel Lesinski" <[email-masked]>
Date: Sat, 25 Aug 2007 00:14:33 +0100

I'm writing application that would benefit greatly from being able to use  
Range requests with custom units and range definitions instead of bytes.

The RFC 2616 seems to suggest such possibility in 3.12 Range Units:  
there's a "other-range-unit" defined.

However definition of Content-Range uses "ranges-specifier" and Range uses  
"content-range-spec", which both seem to allow only byte ranges.

In such case, is there any use for "other-range-unit" in Accept-Ranges?

If I wish to use custom ranges, should I stay clear of Range/Content-Range  
and status 206? What is the best alternative? (custom headers + Vary?  
Piggybacking my range spec on E-Tags?)

-- 
regards, Kornel Lesinski

---

From: Yaron Goland <[email-masked]>
Date: Wed, 29 Aug 2007 14:30:58 -0700

I ran into this exact same problem. In the end we choose another approach but the lack of a definition in RFC 2616 on how to extend ranges was a problem. Another big problem is that certain servers (who shall remain nameless) seem to believe that the range values must be integers. I don't see anything in RFC 2616 that seems to require that. But RFC 2616 does seem ambiguous on the subject. This would seem like a good issue for the HTTPBis issue list.

        Thanks,

                Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Kornel Lesinski
> Sent: Friday, August 24, 2007 4:15 PM
> To: [email-masked]
> Subject: Custom Ranges
>
>
>

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 31 Aug 2007 08:40:51 -0700

What I remember was that I pushed for custom ranges and that there was
a lot of push-back from people who thought it was too much complexity.

I think the idea 'sort of' got into the spec, but not fully fleshed out.

I agree that it belongs in the issue list, to either clarify how to
use custom ranges (with a range unit registry, for example) or else
to remove the feature.

Larry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaron Goland
Sent: Wednesday, August 29, 2007 2:31 PM
To: Kornel Lesinski; [email-masked]
Subject: RE: Custom Ranges

        Thanks,

                Yaron