Subject: Revised charter proposal

From: Mark Nottingham <[email-masked]>
Date: Thu, 13 Sep 2007 23:35:44 +1000

[ Updated as per list feedback; dates shifted forward slightly. ]

HyperText Transfer Protocol Revision (http-bis) Charter

Last Modified: 2007-09-13

Chair(s):
[TBD]

Applications Area Director(s):
Chris Newman <[email-masked]>
Lisa Dusseault <[email-masked]>

Applications Area Advisor:
[TBD]

Mailing Lists:
General Discussion: [email-masked]
To Subscribe: [email-masked]
In Subject: subscribe
Archive: http://lists.w3.org/Archives/Public/ietf-http-wg/

Description of Working Group:
HTTP is one of the most successful and widely-used protocols on the  
Internet today. However, its specification has several editorial  
issues. Additionally, after years of implementation and extension,  
several ambiguities have become evident, impairing interoperability  
and the ability to easily implement and use HTTP.

The working group will refine RFC2616 to:
   * Incorporate errata and updates (e.g., references, IANA  
registries, ABNF)
   * Fix editorial problems which have led to misunderstandings of  
the specification
   * Clarify conformance requirements
   * Remove known ambiguities where they affect interoperability
   * Clarify existing methods of extensibility
   * Remove or deprecate those features that are not widely  
implemented and also unduly affect interoperability
   * Where necessary, add implementation advice
   * Document the security properties of HTTP and its associated  
mechanisms (e.g., Basic and Digest authentication, cookies, TLS) for  
common applications

In doing so, it should consider:
   * Implementer experience
   * Demonstrated use of HTTP
   * Impact on existing implementations and deployments

The Working Group must not introduce a new version of HTTP, and  
should not introduce new features or capabilities to HTTP.

The Working Group's specification deliverables are:
    * A document that is suitable to supersede RFC 2616
    * A document cataloguing the security properties of HTTP

Additionally, the Working Group may review (and document) test suites  
for HTTP conformance, as they are made available.

Goals and Milestones:
Nov 2007 - First HTTP Revision Internet Draft
Dec 2007 - IETF 70 Meeting, Vancouver, BC, CA
Feb 2008 - First HTTP Security Properties Internet Draft
Mar 2008 - IETF 71 Meeting, Philadelphia, PA, USA
Jun 2008 - Request Last Call for HTTP Revision
Jul 2008 - IETF 72 Meeting, TBD
Jul 2008 - Request Last Call for HTTP Security Properties
Oct 2008 - Submit HTTP Revision to IESG for consideration as a Draft  
Standard
Oct 2008 - Submit HTTP Security Properties to IESG for consideration  
as Informational

--
Mark Nottingham     http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Sat, 15 Sep 2007 12:06:33 +0200

Mark Nottingham wrote:
> ...

Sounds good to me.

Best regards, Julian