Subject: status of delta compression (encoding) for HTTP servers/browsers?

From: Andy King <[email-masked]>
Date: Tue, 09 Oct 2007 15:35:22 +0000

hi,

i'm writing a book and would like to include a section on
http delta compression. i found two products that do delta,
does anybody know any others that are available now?

do these both work by using javascript to send delta?
anybody tested these?

it appears that netscaler is here:

citrix netscaler
<http://www.citrix.com/English/ps2/products/product.asp?contentID=21679>http://www.citrix.com/English/ps2/products/product.asp?contentID=21679

and fineground is now part of cisco's application velocity software:
<http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/avs/v60/release/notes/AVS60RN.html>http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/avs/v60/release/notes/AVS60RN.html

thanks,

- andy

Andrew B. King, MSME  [email-masked]
Founder:              WebSiteOptimization.com, Optimizationweek.com, 
WebReference.com, JavaScript.com
Author:               Speed Up Your Site: Web Site Optimization -> 
SpeedUpYourSite.com
Voice:                734.476.6611    Fax 734.661.1331

---

From: Eric Lawrence <[email-masked]>
Date: Tue, 9 Oct 2007 14:31:45 -0700

I'm sure delta compression is used in many specialized applications, but I do not know of browsers that support it in the general case.

http://www.wyman.us/main/2004/09/using_rfc3229_w.html is the only general-purpose, broadly deployed use of delta that I've heard of.  The Windows RSS platform supports this feature, as do a number of other RSS clients.

Eric Lawrence
Want to view and tamper with HTTP(S) traffic?
Try http://www.fiddler2.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy King
Sent: Tuesday, October 09, 2007 8:35 AM
To: [email-masked]
Subject: status of delta compression (encoding) for HTTP servers/browsers?

hi,

citrix netscaler

thanks,

- andy