Subject: Re: PUT, side effects and 201 Created? [ i21 ]

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 Jan 2008 23:27:44 +1100

<http://www3.tools.ietf.org/wg/httpbis/trac/ticket/21>

There hasn't been discussion on this in a while - still worth doing?

Personally, I'd say it's a small but worthwhile improvement, and  
perhaps more importantly, pretty safe to do.

On 04/04/2006, at 5:23 PM, Stefan Eissing wrote:

>
>
> Am 04.04.2006 um 01:25 schrieb Mark Nottingham:
>>
>> I.e., read literally, the above requirement requires a 201 Created  
>> when PUT results in *any* resource being created -- even as a side  
>> effect.
>>
>> This is IMO unnecessarily constraining, and should be relaxed;  
>> e.g., changed to something like
>>
>> "If a new resource is created at the Request-URI, the origin server  
>> MUST inform the user agent via the 201 (Created) response."
>
> I'd file that under clarification. I think you give a clearer  
> formulation of what the spec writers did intend to say.
>
> //Stefan
>
>
>
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Jan 2008 13:40:35 +0100

Mark Nottingham wrote:
> Personally, I'd say it's a small but worthwhile improvement, and perhaps 
> more importantly, pretty safe to do.

+1.

BR, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 30 Jan 2008 21:22:07 +1100

Closing with proposed text.