Subject: Re: 100-continue implementation status question

From: Julian Reschke <[email-masked]>
Date: Sun, 01 Jun 2008 14:50:06 +0200

Julian Reschke wrote:
> 
> Paul Leach wrote:
>>
>>
>> Can people help with the following question:
>>
>> How widely implemented is 100-continue? And how correctly?
>> ...
> 
> In Java servlet world: the servers do implement it partly.
> 
> That is, they understand Expect: 100-continue, and reply with 100 
> Continue when asked for it.
> 
> However, the containers do not let the servlets have a say (inspecting 
> the request, and potentially saying "417 Expectation Failed"). This is a 
> restriction that has been known for a long time, and I certainly hope 
> the Java Servlet EG will address that at some point of time (I haven't 
> checked recently, so maybe they already did and I missed it).

Speaking of which... does anybody know whether the Servlet EG is 
following this mailing list?

BR, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 2 Jun 2008 13:24:00 +1000

I've fired off a message.

On 01/06/2008, at 10:50 PM, Julian Reschke wrote:

>> However, the containers do not let the servlets have a say  
>> (inspecting the request, and potentially saying "417 Expectation  
>> Failed"). This is a restriction that has been known for a long  
>> time, and I certainly hope the Java Servlet EG will address that at  
>> some point of time (I haven't checked recently, so maybe they  
>> already did and I missed it).
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Henrik Nordstrom <[email-masked]>
Date: Mon, 02 Jun 2008 21:08:15 +0200

tor 2008-04-24 klockan 23:03 -0700 skrev Paul Leach:
> In particular, one thing I'd like to know is whether, when
> authentication is needed, servers typically send back 401 instead of
> 100.

They SHOULD.

100 Continue should only be sent after authentication have completed and
it's ok to process the request.

Regards
Henrik