Subject: Fwd: Status of Link header

From: Mark Nottingham <[email-masked]>
Date: Mon, 22 Sep 2008 21:25:37 +1000

Forgot to forward this...

Begin forwarded message:

> From: "Tantek Celik" <[email-masked]>
> Date: 12 September 2008 6:53:53 PM
> To: "Mark Nottingham" <[email-masked]>
> Subject: Re: Status of Link header
> Reply-To: [email-masked]
>
> FWIW I'd suggest *not* including the rev attribute due to rampant  
> author misunderstanding/misuse. We've decided to deprecate it  
> microformats and not use it for anything new:
>
> http://microformats.org/wiki/rel-faq#Should_rev_even_be_used
>
> hreflang attribute makes sense - it has good use cases, is used in  
> the wild in HTML (e.g. http://gmpg.org/xfn/creator ) and would be  
> nice to be able to use as part of the HTTP header rather than inline  
> in the document.
>
> HTH and feel free to fwd/share this email. I'm not on all those  
> lists so I thought private reply would work best.
>
> Hope u r doing well!
>
> Tantek
>
> -----Original Message-----
> From: Mark Nottingham <[email-masked]>
>
> Date: Fri, 12 Sep 2008 16:50:23
> To: HTTP Working Group<[email-masked]>
> Cc: Atom Syntax<[email-masked]>; <[email-masked]>; HTML WG<[email-masked] 
> >
> Subject: Status of Link header
>
>
>
> For those wondering what/where/how things are going with the Link
> header draft <http://ietfreport.isoc.org/idref/draft-nottingham-http-link-header/
>> , I'm currently working on an -03 version. Potential changes include
> (feel free to discuss);
>
>  - Re-adding the 'rev' attribute (I've had a few requests for
> specific use cases; not yet convinced either way)
>  - Considering adding a 'hreflang' attribute
>  - Clarifying the requirements for registering relations WRT format-
> specificity
>
> Any comments or other input would be appreciated.
>
> Cheers,
>
>
> --
> Mark Nottingham     http://www.mnot.net/
>
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Sep 2008 13:55:12 +0200

>> http://microformats.org/wiki/rel-faq#Should_rev_even_be_used

I agree that "rev" is problematic.

However, it *is* in HTML4 and RFC2068, so I think it would be better to 
keep it in.

If people need "rev" (when there's no inverse relation defined), they 
will use it anyway, right?

 > ...

BR, Julian