Subject: Status of RFC 2295: Transparent Content Negotiation in HTTP (Experimental)

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 13 Jan 2009 11:11:31 -0700

I was just made aware of experimental RFC 2295 [1] (via Anthony Bryan / Metalink [2]) which is directly related to my recent HTTP-based Resource Descriptor Discovery draft [3]. Does anyone know the status of this RFC? Has it been widely deployed? Is there any documented experience with it?

EHL

[1] http://tools.ietf.org/html/rfc2295
[2] http://tools.ietf.org/html/draft-bryan-metalink-05
[3] http://tools.ietf.org/html/draft-hammer-discovery-00

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Jan 2009 17:53:21 +1100

It's implemented in Apache, and has been for some time;
  http://httpd.apache.org/docs/2.0/content-negotiation.html

See also:
  http://gewis.win.tue.nl/~koen/conneg/

To my knowledge, caching intermediaries haven't deployed it (i.e.,  
they'll work with TCN, but they won't be able to serve negotiated  
requests from cache... somebody please correct me if I'm wrong).

I'm not sure about browser implementation, but I did a quick check of  
the request headers seen by a very high-traffic Web site, and a  
vanishingly small number contained the Negotiate header...

Cheers,

On 14/01/2009, at 5:11 AM, Eran Hammer-Lahav wrote:

>
> I was just made aware of experimental RFC 2295 [1] (via Anthony  
> Bryan / Metalink [2]) which is directly related to my recent HTTP- 
> based Resource Descriptor Discovery draft [3]. Does anyone know the  
> status of this RFC? Has it been widely deployed? Is there any  
> documented experience with it?
>
>
> EHL
>

--
Mark Nottingham     http://www.mnot.net/